summaryrefslogtreecommitdiff
path: root/packages/linux/linux-2.6.23
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-11-30 12:13:18 +0000
committerKoen Kooi <koen@openembedded.org>2007-11-30 12:13:18 +0000
commit77fe3e9053a6f21bd39e8bd3a49b62bb7bb00344 (patch)
tree7f47744119f4a6854c7681007a87a466e173fc01 /packages/linux/linux-2.6.23
parenta621a4ae2f282efbfa6da80a1dbe6a2e8ebc3aff (diff)
parentdf583e53b537df5d9becc184789d641ec0788c11 (diff)
propagate from branch 'org.openembedded.dev' (head f7531c375389681cc06ea3169fea009301b94267)
to branch 'org.openembedded.dev.avr32' (head f1af8a59e078436ab2999eef666d653dd9d4ed05)
Diffstat (limited to 'packages/linux/linux-2.6.23')
-rw-r--r--packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch2
-rw-r--r--packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-rtc.patch32
2 files changed, 33 insertions, 1 deletions
diff --git a/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch b/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch
index d8a477af2a..0310746dfe 100644
--- a/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch
+++ b/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch
@@ -145,7 +145,7 @@ diff -urN linux-2.6.23.orig/drivers/leds/leds-mpc8313e-rdb.c linux-2.6.23/driver
+
+MODULE_AUTHOR("Leon Woestenberg <leon@sidebranch.com>");
+MODULE_DESCRIPTION("MPC8313E-RDB LED driver");
-+
++MODULE_LICENSE("GPL");
diff -urN linux-2.6.23.orig/drivers/leds/Makefile linux-2.6.23/drivers/leds/Makefile
--- linux-2.6.23.orig/drivers/leds/Makefile 2007-10-09 22:31:38.000000000 +0200
+++ linux-2.6.23/drivers/leds/Makefile 2007-11-29 09:03:09.000000000 +0100
diff --git a/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-rtc.patch b/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-rtc.patch
new file mode 100644
index 0000000000..7c6cbcaa0b
--- /dev/null
+++ b/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-rtc.patch
@@ -0,0 +1,32 @@
+diff -urN linux-2.6.23.orig/arch/powerpc/boot/dts/mpc8313erdb.dts linux-2.6.23/arch/powerpc/boot/dts/mpc8313erdb.dts
+--- linux-2.6.23.orig/arch/powerpc/boot/dts/mpc8313erdb.dts 2007-10-09 22:31:38.000000000 +0200
++++ linux-2.6.23/arch/powerpc/boot/dts/mpc8313erdb.dts 2007-11-29 19:32:21.000000000 +0100
+@@ -60,6 +60,12 @@
+ interrupts = <e 8>;
+ interrupt-parent = < &ipic >;
+ dfsrr;
++
++ rtc@68 {
++ device_type = "rtc";
++ compatible = "dallas,ds1339";
++ reg = <68>;
++ };
+ };
+
+ i2c@3100 {
+diff -urN linux-2.6.23.orig/arch/powerpc/sysdev/fsl_soc.c linux-2.6.23/arch/powerpc/sysdev/fsl_soc.c
+--- linux-2.6.23.orig/arch/powerpc/sysdev/fsl_soc.c 2007-10-09 22:31:38.000000000 +0200
++++ linux-2.6.23/arch/powerpc/sysdev/fsl_soc.c 2007-11-29 19:31:58.000000000 +0100
+@@ -319,6 +319,12 @@
+ {"ricoh,rs5c372b", "rtc-rs5c372", "rs5c372b",},
+ {"ricoh,rv5c386", "rtc-rs5c372", "rv5c386",},
+ {"ricoh,rv5c387a", "rtc-rs5c372", "rv5c387a",},
++ {"dallas,ds1307", "rtc-ds1307", "ds1307",},
++ {"dallas,ds1337", "rtc-ds1307", "ds1337",},
++ {"dallas,ds1338", "rtc-ds1307", "ds1338",},
++ {"dallas,ds1339", "rtc-ds1307", "ds1339",},
++ {"dallas,ds1340", "rtc-ds1307", "ds1340",},
++ {"stm,m41t00", "rtc-ds1307", "m41t00"},
+ };
+
+ static int __init of_find_i2c_driver(struct device_node *node, struct i2c_board_info *info)