summaryrefslogtreecommitdiff
path: root/packages/linux/linux-2.6.23/mpc8313e-rdb
diff options
context:
space:
mode:
authorJeremy Laine <jeremy.laine@m4x.org>2007-11-29 08:16:33 +0000
committerJeremy Laine <jeremy.laine@m4x.org>2007-11-29 08:16:33 +0000
commit5c0de96fc41ea8a72d56e5489a2dc0bd11429ab3 (patch)
tree4d652f4fb12d747551b531366f5abb7b49db4ad6 /packages/linux/linux-2.6.23/mpc8313e-rdb
parent3b0a73545371730ebe36bf749de235cd429203ff (diff)
linux-2.6.23: fix mpc8313e-rdb LEDs patch (didn't apply cleanly)
Diffstat (limited to 'packages/linux/linux-2.6.23/mpc8313e-rdb')
-rw-r--r--packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch23
1 files changed, 10 insertions, 13 deletions
diff --git a/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch b/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch
index 7eadfc61fe..d8a477af2a 100644
--- a/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch
+++ b/packages/linux/linux-2.6.23/mpc8313e-rdb/mpc8313e-rdb-leds.patch
@@ -1,7 +1,6 @@
-Index: linux-2.6.23/drivers/leds/Kconfig
-===================================================================
+diff -urN linux-2.6.23.orig/drivers/leds/Kconfig linux-2.6.23/drivers/leds/Kconfig
--- linux-2.6.23.orig/drivers/leds/Kconfig 2007-10-09 22:31:38.000000000 +0200
-+++ linux-2.6.23/drivers/leds/Kconfig 2007-11-28 23:16:05.000000000 +0100
++++ linux-2.6.23/drivers/leds/Kconfig 2007-11-29 09:02:42.000000000 +0100
@@ -101,6 +101,12 @@
outputs. To be useful the particular board must have LEDs
and they must be connected to the GPIO lines.
@@ -15,10 +14,9 @@ Index: linux-2.6.23/drivers/leds/Kconfig
comment "LED Triggers"
config LEDS_TRIGGERS
-Index: linux-2.6.23/drivers/leds/leds-mpc8313e-rdb.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.23/drivers/leds/leds-mpc8313e-rdb.c 2007-11-29 00:45:42.000000000 +0100
+diff -urN linux-2.6.23.orig/drivers/leds/leds-mpc8313e-rdb.c linux-2.6.23/drivers/leds/leds-mpc8313e-rdb.c
+--- linux-2.6.23.orig/drivers/leds/leds-mpc8313e-rdb.c 1970-01-01 01:00:00.000000000 +0100
++++ linux-2.6.23/drivers/leds/leds-mpc8313e-rdb.c 2007-11-29 09:02:42.000000000 +0100
@@ -0,0 +1,128 @@
+/*
+ * drivers/leds/leds-mpc8313e-rdb.c
@@ -148,15 +146,14 @@ Index: linux-2.6.23/drivers/leds/leds-mpc8313e-rdb.c
+MODULE_AUTHOR("Leon Woestenberg <leon@sidebranch.com>");
+MODULE_DESCRIPTION("MPC8313E-RDB LED driver");
+
-Index: linux-2.6.23/drivers/leds/Makefile
-===================================================================
---- linux-2.6.23.orig/drivers/leds/Makefile 2007-11-28 23:17:29.000000000 +0100
-+++ linux-2.6.23/drivers/leds/Makefile 2007-11-28 23:35:32.000000000 +0100
+diff -urN linux-2.6.23.orig/drivers/leds/Makefile linux-2.6.23/drivers/leds/Makefile
+--- linux-2.6.23.orig/drivers/leds/Makefile 2007-10-09 22:31:38.000000000 +0200
++++ linux-2.6.23/drivers/leds/Makefile 2007-11-29 09:03:09.000000000 +0100
@@ -17,6 +17,7 @@
obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
obj-$(CONFIG_LEDS_COBALT) += leds-cobalt.o
obj-$(CONFIG_LEDS_GPIO) += leds-gpio.o
+obj-$(CONFIG_LEDS_MPC8313E_RDB) += leds-mpc8313e-rdb.o
-
+
# LED Triggers
- obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
+ obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o