summaryrefslogtreecommitdiff
path: root/packages/linux/linux-2.6.18/avr32-sound.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-08-12 08:40:57 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-12 08:40:57 +0000
commit87de1e8d939bda416ebed28c492fd5515d6581a1 (patch)
tree0940553b47b553b2ff90d7c84c4d8cce42806dbe /packages/linux/linux-2.6.18/avr32-sound.patch
parent865f9b1ff4f04bf80a9adab5a0a179e53fdd93e9 (diff)
parent2a515b9b1760e1474d2b257e68c00998297f422c (diff)
propagate from branch 'org.openembedded.dev' (head 0f0f223484d369b6dd3347b0af81e9043083a3a6)
to branch 'org.openembedded.dev.avr32' (head 979e73021b273ae65b6f3b1f59da5efb6f436a3d)
Diffstat (limited to 'packages/linux/linux-2.6.18/avr32-sound.patch')
-rw-r--r--packages/linux/linux-2.6.18/avr32-sound.patch51
1 files changed, 51 insertions, 0 deletions
diff --git a/packages/linux/linux-2.6.18/avr32-sound.patch b/packages/linux/linux-2.6.18/avr32-sound.patch
new file mode 100644
index 0000000000..597a44de3b
--- /dev/null
+++ b/packages/linux/linux-2.6.18/avr32-sound.patch
@@ -0,0 +1,51 @@
+---
+ sound/Kconfig | 2 ++
+ sound/Makefile | 1 +
+ sound/avr32/Kconfig | 6 ++++++
+ sound/avr32/Makefile | 3 +++
+ 4 files changed, 12 insertions(+)
+
+Index: linux-2.6.18-avr32/sound/Kconfig
+===================================================================
+--- linux-2.6.18-avr32.orig/sound/Kconfig 2006-09-12 10:44:15.000000000 +0200
++++ linux-2.6.18-avr32/sound/Kconfig 2006-09-12 10:45:14.000000000 +0200
+@@ -62,6 +62,8 @@ source "sound/aoa/Kconfig"
+
+ source "sound/arm/Kconfig"
+
++source "sound/avr32/Kconfig"
++
+ source "sound/mips/Kconfig"
+
+ # the following will depenend on the order of config.
+Index: linux-2.6.18-avr32/sound/Makefile
+===================================================================
+--- linux-2.6.18-avr32.orig/sound/Makefile 2006-09-12 10:44:15.000000000 +0200
++++ linux-2.6.18-avr32/sound/Makefile 2006-09-12 10:44:37.000000000 +0200
+@@ -5,6 +5,7 @@ obj-$(CONFIG_SOUND) += soundcore.o
+ obj-$(CONFIG_SOUND_PRIME) += oss/
+ obj-$(CONFIG_DMASOUND) += oss/
+ obj-$(CONFIG_SND) += core/ i2c/ drivers/ isa/ pci/ ppc/ arm/ synth/ usb/ sparc/ parisc/ pcmcia/ mips/
++obj-$(CONFIG_SND) += avr32/
+ obj-$(CONFIG_SND_AOA) += aoa/
+
+ ifeq ($(CONFIG_SND),y)
+Index: linux-2.6.18-avr32/sound/avr32/Kconfig
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.18-avr32/sound/avr32/Kconfig 2006-09-12 10:45:52.000000000 +0200
+@@ -0,0 +1,6 @@
++# ALSA AVR32 drivers
++
++menu "ALSA AVR32 devices"
++ depends on SND != n && AVR32
++
++endmenu
+Index: linux-2.6.18-avr32/sound/avr32/Makefile
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ linux-2.6.18-avr32/sound/avr32/Makefile 2006-09-12 10:46:03.000000000 +0200
+@@ -0,0 +1,3 @@
++#
++# Makefile for ALSA
++#