summaryrefslogtreecommitdiff
path: root/packages/linux/ixp4xx-kernel_2.6.20.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2007-02-09 07:26:16 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2007-02-09 07:26:16 +0000
commite77d902b1e761e250f98a30ea72175195315523f (patch)
treeb495670388e5a6ecf15ce150a0052564cbfba897 /packages/linux/ixp4xx-kernel_2.6.20.bb
parent40c1e273c38777cd265c959fd21b408ab891d494 (diff)
parenta46f44bbc59cb2c6c9c0b55976603f134ec35467 (diff)
merge of '1ced81b8e37ff2e92b41ce7ba7c6d5482c409182'
and 'b5e0b951b33635fff4584dd883c6750daba2ece3'
Diffstat (limited to 'packages/linux/ixp4xx-kernel_2.6.20.bb')
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.20.bb15
1 files changed, 14 insertions, 1 deletions
diff --git a/packages/linux/ixp4xx-kernel_2.6.20.bb b/packages/linux/ixp4xx-kernel_2.6.20.bb
index 304866c555..3af3556845 100644
--- a/packages/linux/ixp4xx-kernel_2.6.20.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.20.bb
@@ -6,7 +6,7 @@
# http://trac.nslu2-linux.org/kernel/
#
# The revision that is pulled from SVN is specified below
-IXP4XX_KERNEL_SVN_REV = "682"
+IXP4XX_KERNEL_SVN_REV = "683"
#
# The directory containing the patches to be applied is
# specified below
@@ -23,3 +23,16 @@ require ixp4xx-kernel-svnpatch.inc
SRC_URI += "file://defconfig"
SRC_URI += "file://series"
+
+# Remove the specific cmdline hacking patches if we are not building for nslu2.
+addtask remove_cmdline_hacks before do_patch after do_unpack
+do_remove_cmdline_hacks() {
+
+ if [ "${MACHINE}" != "nslu2" ] ; then
+ sed -e '/88-nas100d-dflt-cmdline.patch/d' \
+ -e '/88-nslu2-dflt-cmdline.patch/d' \
+ '${WORKDIR}/series' > '${WORKDIR}/series.new'
+ mv '${WORKDIR}/series.new' '${WORKDIR}/series'
+ fi
+
+}