summaryrefslogtreecommitdiff
path: root/packages/linux/ixp4xx-kernel_2.6.20.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-02-07 10:49:33 +0000
committerRod Whitby <rod@whitby.id.au>2007-02-07 10:49:33 +0000
commitd41c3f9d14e92d9339dabb60a838c2f276828d01 (patch)
tree520059c9dea2c23cf2f71c79353338641677fa98 /packages/linux/ixp4xx-kernel_2.6.20.bb
parent1e3db2356d5f2c1f963ffdb664f77d49b0fe02ca (diff)
slugos: backed out of using arm-kernel-shim instead of the cmdline hacks, cause arm-kernel-shim doesn't work on LE
Diffstat (limited to 'packages/linux/ixp4xx-kernel_2.6.20.bb')
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.20.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/packages/linux/ixp4xx-kernel_2.6.20.bb b/packages/linux/ixp4xx-kernel_2.6.20.bb
index 304866c555..0cc6b387f7 100644
--- a/packages/linux/ixp4xx-kernel_2.6.20.bb
+++ b/packages/linux/ixp4xx-kernel_2.6.20.bb
@@ -23,3 +23,16 @@ require ixp4xx-kernel-svnpatch.inc
SRC_URI += "file://defconfig"
SRC_URI += "file://series"
+
+# Remove the specific cmdline hacking patches if we are not building for nslu2.
+addtask remove_cmdline_hacks before do_patch after do_unpack
+do_remove_cmdline_hacks() {
+
+ if [ "${MACHINE}" != "nslu2" ] ; then
+ sed -e '/88-nas100d-dflt-cmdline.patch/d' \
+ -e '/88-nslu2-dflt-cmdline.patch/d' \
+ '${WORKDIR}/series' > '${WORKDIR}/series.new'
+ mv '${WORKDIR}/series.new' '${WORKDIR}/series'
+ fi
+
+}