summaryrefslogtreecommitdiff
path: root/packages/linux/ixp4xx-kernel_2.6.20.bb
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-02-04 20:58:12 +0000
committerRod Whitby <rod@whitby.id.au>2007-02-04 20:58:12 +0000
commit18338970d6b0f87856fa6c7a6b31c93d00adeb70 (patch)
tree0aeb7e1732a77420680c0f680516edd2a532ecdb /packages/linux/ixp4xx-kernel_2.6.20.bb
parent6ad0539c5f00b80f229e5fcf7bb89e9e9f74df85 (diff)
ixp4xx-kernel: Updated to 2.6.20
Diffstat (limited to 'packages/linux/ixp4xx-kernel_2.6.20.bb')
-rw-r--r--packages/linux/ixp4xx-kernel_2.6.20.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/linux/ixp4xx-kernel_2.6.20.bb b/packages/linux/ixp4xx-kernel_2.6.20.bb
new file mode 100644
index 0000000000..0cc6b387f7
--- /dev/null
+++ b/packages/linux/ixp4xx-kernel_2.6.20.bb
@@ -0,0 +1,38 @@
+# Kernel for IXP4xx
+#
+# This bitbake file pulls patches and the defconfig straight
+# from the NSLU2-Linux SVN repository. Information about this
+# repository can be found at:
+# http://trac.nslu2-linux.org/kernel/
+#
+# The revision that is pulled from SVN is specified below
+IXP4XX_KERNEL_SVN_REV = "682"
+#
+# The directory containing the patches to be applied is
+# specified below
+IXP4XX_KERNEL_PATCH_DIR = "2.6.20"
+#
+# Increment the number below (i.e. the digits after PR) when
+# the changes in SVN between revisions include changes in the
+# patches applied to the kernel, rather than simply defconfig
+# changes
+PR = "r1.${IXP4XX_KERNEL_SVN_REV}"
+
+require ixp4xx-kernel.inc
+require ixp4xx-kernel-svnpatch.inc
+
+SRC_URI += "file://defconfig"
+SRC_URI += "file://series"
+
+# Remove the specific cmdline hacking patches if we are not building for nslu2.
+addtask remove_cmdline_hacks before do_patch after do_unpack
+do_remove_cmdline_hacks() {
+
+ if [ "${MACHINE}" != "nslu2" ] ; then
+ sed -e '/88-nas100d-dflt-cmdline.patch/d' \
+ -e '/88-nslu2-dflt-cmdline.patch/d' \
+ '${WORKDIR}/series' > '${WORKDIR}/series.new'
+ mv '${WORKDIR}/series.new' '${WORKDIR}/series'
+ fi
+
+}