summaryrefslogtreecommitdiff
path: root/packages/linux/handhelds-pxa-2.6_2.6.12-hh1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/linux/handhelds-pxa-2.6_2.6.12-hh1.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/linux/handhelds-pxa-2.6_2.6.12-hh1.bb')
-rw-r--r--packages/linux/handhelds-pxa-2.6_2.6.12-hh1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/linux/handhelds-pxa-2.6_2.6.12-hh1.bb b/packages/linux/handhelds-pxa-2.6_2.6.12-hh1.bb
index e69de29bb2..1ecc553cf9 100644
--- a/packages/linux/handhelds-pxa-2.6_2.6.12-hh1.bb
+++ b/packages/linux/handhelds-pxa-2.6_2.6.12-hh1.bb
@@ -0,0 +1,25 @@
+SECTION = "kernel"
+DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
+MAINTAINER = "Greg Gilbert <greg@treke.net>"
+LICENSE = "GPL"
+#
+COMPATIBLE_HOST = "arm.*-linux"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')}"
+
+S = "${WORKDIR}/kernel26"
+
+inherit kernel
+
+K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
+K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
+K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
+HHV = "${@bb.data.getVar('PV',d,1).split('-')[1].split('hh')[-1]}"
+
+KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
+do_configure() {
+ install -m 0644 arch/arm/configs/ipaqpxa_defconfig .config
+ yes '' | oe_runmake oldconfig
+}