summaryrefslogtreecommitdiff
path: root/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/linux/gumstix_2.6.5-gnalm1-gum0.bb')
-rw-r--r--packages/linux/gumstix_2.6.5-gnalm1-gum0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb b/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
index e69de29bb2..9bf400a9f7 100644
--- a/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
+++ b/packages/linux/gumstix_2.6.5-gnalm1-gum0.bb
@@ -0,0 +1,26 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for OMAP processors"
+LICENSE = "GPL"
+
+# NOTE: pulled local linux-2.6.5-gnalm1, since it didn't apply cleanly
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.5.tar.bz2 \
+ file://linux-2.6.5-gnalm1.patch;patch=1 \
+ http://gumstix.superlucidity.net/downloads/kernel/patches/linux-2.6.5-gnalm1-gum0.patch;patch=1 \
+ file://defconfig"
+S = "${WORKDIR}/linux-2.6.5"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "zImage"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config || die "no default configuration for ${MACHINE} available."
+ oe_runmake oldconfig
+}
+
+python __anonymous () {
+ import re
+ host = bb.data.getVar('HOST_SYS', d, 1)
+ if not re.match('arm.*-linux', host):
+ raise bb.parse.SkipPackage("incompatible with host %s" % host)
+}