summaryrefslogtreecommitdiff
path: root/packages/linux/ep93xx-kernel_2.6.16.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-03-24 11:26:52 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-24 11:26:52 +0000
commitcf64b704c29e386a1f3f61d993aa243ec59a7120 (patch)
tree32e742db90763d3c4a1858c8fa1ec64ab4b27ddc /packages/linux/ep93xx-kernel_2.6.16.bb
parent0526fda9c4adef16007c4029d62e300110918adf (diff)
ep93xx kernel: update to 2.6.16
* use derevo17 * integrate framebuffer patches * turn on EABI and old ABI compat
Diffstat (limited to 'packages/linux/ep93xx-kernel_2.6.16.bb')
-rw-r--r--packages/linux/ep93xx-kernel_2.6.16.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/linux/ep93xx-kernel_2.6.16.bb b/packages/linux/ep93xx-kernel_2.6.16.bb
new file mode 100644
index 0000000000..1806290a67
--- /dev/null
+++ b/packages/linux/ep93xx-kernel_2.6.16.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Linux Kernel for Cirrus Logic ep39xx compatible machines"
+SECTION = "kernel"
+MAINTAINER = "Koen Kooi <koen@dominion.kabel.utwente.nl>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
+ http://www.wantstofly.org/~buytenh/ep93xx/derevo17.diff;patch=1 \
+ http://cowebs.contec.at/ep93xx/EP93XX_Framebuffer1.patch;patch=1 \
+ http://cowebs.contec.at/ep93xx/EP93XX_Framebuffer1_registers.patch;patch=1 \
+ http://cowebs.contec.at/ep93xx/EP93XX_Framebuffer1_registers_raster.patch;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-2.6.16"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "zImage"
+
+do_configure() {
+ install -m 644 ${WORKDIR}/defconfig ${S}/.config
+ make ARCH=arm oldconfig
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+
+