summaryrefslogtreecommitdiff
path: root/packages/linux/ep93xx-kernel_2.6.16.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-04-27 16:09:08 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-27 16:09:08 +0000
commitbc55050886bd05cac03a20a1fa84e3aedc7a547d (patch)
treec6073d0e6f478d9be849db37a16984a734906956 /packages/linux/ep93xx-kernel_2.6.16.bb
parentcea4c3d023db29f9ddf75dba403262dd9932d1f7 (diff)
ep93xx 2.6.16: apply eabi enums patch
Diffstat (limited to 'packages/linux/ep93xx-kernel_2.6.16.bb')
-rw-r--r--packages/linux/ep93xx-kernel_2.6.16.bb27
1 files changed, 24 insertions, 3 deletions
diff --git a/packages/linux/ep93xx-kernel_2.6.16.bb b/packages/linux/ep93xx-kernel_2.6.16.bb
index a472e9379c..068b9671d0 100644
--- a/packages/linux/ep93xx-kernel_2.6.16.bb
+++ b/packages/linux/ep93xx-kernel_2.6.16.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Linux Kernel for Cirrus Logic ep39xx compatible machines"
SECTION = "kernel"
MAINTAINER = "Koen Kooi <koen@dominion.kabel.utwente.nl>"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
COMPATIBLE_MACHINE = "ep93xx"
@@ -11,6 +11,7 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.16.tar.bz2 \
http://cowebs.contec.at/ep93xx/EP93XX_Framebuffer1.patch;patch=1 \
http://cowebs.contec.at/ep93xx/EP93XX_Framebuffer1_registers.patch;patch=1 \
http://cowebs.contec.at/ep93xx/EP93XX_Framebuffer1_registers_raster.patch;patch=1 \
+ file://eabi-enums.patch;patch=1 \
file://defconfig \
"
@@ -21,8 +22,28 @@ inherit kernel
KERNEL_IMAGETYPE = "zImage"
do_configure() {
- install -m 644 ${WORKDIR}/defconfig ${S}/.config
- make ARCH=arm oldconfig
+ rm -f ${S}/.config
+
+ if [ ! -e ${WORKDIR}/defconfig ]; then
+ die "No default configuration for ${MACHINE} available."
+ fi
+
+
+ if [ "${TARGET_OS}" == "linux-gnueabi" ]; then
+ echo "CONFIG_AEABI=y" >> ${S}/.config
+ echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
+ else
+ echo "# CONFIG_AEABI is not set" >> ${S}/.config
+ echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
+ fi
+
+ sed -e '/CONFIG_AEABI/d' \
+ -e '/CONFIG_OABI_COMPAT=/d' \
+ '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
+
+
}
do_deploy() {