summaryrefslogtreecommitdiff
path: root/packages/linux-libc-headers
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-03-23 14:08:06 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-03-23 14:08:06 +0000
commitc441bcc8f3371a91baeef98c55ffc6d147182fd7 (patch)
tree9d3225013c8afff1d944b8cd7cc098acbbda0d0a /packages/linux-libc-headers
parent440118224b248719f3c28547b9b65ad4b73e1cf0 (diff)
linux-libc-headers: add UTS_RELEASE to version.h. Fixes uClibc builds with these headers
Diffstat (limited to 'packages/linux-libc-headers')
-rw-r--r--packages/linux-libc-headers/linux-libc-headers_2.6.18.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb b/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
index 8e1c5dc3e8..005b229eab 100644
--- a/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
+++ b/packages/linux-libc-headers/linux-libc-headers_2.6.18.bb
@@ -67,4 +67,10 @@ do_stage () {
cp -pfLR ${STAGE_TEMP}${includedir}/linux ${CROSS_DIR}/${TARGET_SYS}/include/
cp -pfLR ${STAGE_TEMP}${includedir}/asm ${CROSS_DIR}/${TARGET_SYS}/include/
cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${CROSS_DIR}/${TARGET_SYS}/include/
+ # Add UTS_RELEASE to version.h. UTS_RELEASE was moved from version.h to
+ # utsrelease.h in order to avoid recompiling a kernel every time a localversion
+ # changed. Since the our headers are static and we're not compiling an
+ # actual kernel, re-adding UTS_RELEASE does't hurt, and it allows uclibc to
+ # compile with kernel headers that work with EABI on ARM
+ echo '#define UTS_RELEASE "2.6.18"' >> ${CROSS_DIR}/${TARGET_SYS}/include/linux/version.h
}