summaryrefslogtreecommitdiff
path: root/packages/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-08-27 17:17:14 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-08-27 17:17:14 +0000
commitb59ce10791fa913ef0915e48a514f04ca2815977 (patch)
treed6a725e503349f790f6d2a753a41185d94c0090a /packages/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch
parent9f9722dc610bdcf38d278f0e65db0fe805ab5448 (diff)
links-x11_2.1pre21.bb, links_2.1pre12.bb : patches for cookie saving and
preventing segfault on cookies imported from MDK rpms. packages/links/* : drop old versions
Diffstat (limited to 'packages/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch')
-rw-r--r--packages/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch b/packages/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch
new file mode 100644
index 0000000000..0d3b407e2a
--- /dev/null
+++ b/packages/links/files/links-2.1pre17-fix-segfault-on-loading-cookies.patch
@@ -0,0 +1,20 @@
+--- links-2.1pre17/cookies.c.pix 2005-05-15 23:05:10.000000000 +0800
++++ links-2.1pre17/cookies.c 2005-05-15 23:17:21.000000000 +0800
+@@ -41,7 +41,7 @@
+
+ void free_cookie(struct cookie *c)
+ {
+- mem_free(c->name);
++ if (c->value) mem_free(c->name);
+ if (c->value) mem_free(c->value);
+ if (c->server) mem_free(c->server);
+ if (c->path) mem_free(c->path);
+@@ -355,7 +355,7 @@
+
+ inv:
+ free_cookie(cookie);
+- free(cookie);
++ mem_free(cookie);
+ }
+ fclose(fp);
+ }