summaryrefslogtreecommitdiff
path: root/packages/lilo-sh/lilo-sh_21.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-07-03 08:45:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-03 08:45:06 +0000
commit8894f7cfb20ef9fb84217d5bf1dbfd6f9bfec375 (patch)
treedceb32b51b03fe541acdebc41a1cbeda2a9ea8d4 /packages/lilo-sh/lilo-sh_21.bb
parent4e26f686b6c18fe1f57bb20d5edfa81699377ee1 (diff)
parent21dc42547b843538c285d3293ad042425624a61a (diff)
merge of 5672c342d20576efa34f379ef1131d03b578ce6b
and f020c58a9acc8f8db54a7887ff02163ecc5fd3b3
Diffstat (limited to 'packages/lilo-sh/lilo-sh_21.bb')
-rw-r--r--packages/lilo-sh/lilo-sh_21.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/lilo-sh/lilo-sh_21.bb b/packages/lilo-sh/lilo-sh_21.bb
new file mode 100644
index 0000000000..eb4ba0cccf
--- /dev/null
+++ b/packages/lilo-sh/lilo-sh_21.bb
@@ -0,0 +1,41 @@
+#
+# Bootloader for sh4 based devices using a HDD or block translation
+# layer over the flash. NOTE that this version has the 1024 cylinder
+# limit, so you probably need a seperate /boot partition as the first
+# partition on the disk. Tested on the NP51R (Titan) booting from the
+# onboard flash
+#
+DESCRIPTION="LILO (LInux LOader) is a basic system program which \
+boots your Linux system. LILO loads the Linux kernel from a floppy or \
+a hard drive, boots the kernel, and passes control of the system to \
+the kernel. LILO can also boot other operating systems. LILO-sh is a \
+port of LILO to the SH processor."
+SECTION="bootloader"
+MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
+LICENSE = "MIT"
+PR = "r0"
+
+SRC_URI = "http://twibble.org/dist/sh4/src/lilosh/lilo-21.tar.gz \
+ file://lilo-0.21-include.patch;patch=1 \
+ file://lilo-0.21-1.1.patch;patch=1 \
+ file://lilo.patch;patch=1 \
+ file://lilo.raid1;patch=1 \
+ file://lilo-0.21-loopdev.patch;patch=1 \
+ file://lilo-0.21-second.patch;patch=1;pnum=0 \
+ file://lilo-sh-linux.patch;patch=1 \
+ file://lilo-linkgear.patch;patch=1 \
+ file://lilo-noconfig-h.patch;patch=1"
+S = "${WORKDIR}/lilo"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
+
+# Include /boot in the package
+FILES_${PN} = "${base_sbindir} /boot"
+
+do_install() {
+ # Create the base directores
+ mkdir -p ${D}${sysconfdir} ${D}${sbindir}
+ oe_runmake ROOT=${D} install
+ # We don't ship this file
+ rm ${D}/usr/sbin/keytab-lilo.pl
+}