summaryrefslogtreecommitdiff
path: root/packages/lilo-sh/files/lilo-0.21-1.1.patch
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-07-03 03:09:47 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-03 03:09:47 +0000
commit9b820e6f7a397dbf74f92b2596bd58fd2528283b (patch)
tree557abd9a84850f0cec55ac9d2637998df3f1afdb /packages/lilo-sh/files/lilo-0.21-1.1.patch
parentd25e4d60596edd332dbfd2fc63c5e22899ac3600 (diff)
lilo-sh 0.21: Add lilo-sh, a port of the LILO bootloader to the sh
architecture. Required for the titan SH4 boards to boot from the internal flash which has a translation layer to make it look like a standard block device.
Diffstat (limited to 'packages/lilo-sh/files/lilo-0.21-1.1.patch')
-rw-r--r--packages/lilo-sh/files/lilo-0.21-1.1.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/lilo-sh/files/lilo-0.21-1.1.patch b/packages/lilo-sh/files/lilo-0.21-1.1.patch
new file mode 100644
index 0000000000..dfbab2a82c
--- /dev/null
+++ b/packages/lilo-sh/files/lilo-0.21-1.1.patch
@@ -0,0 +1,35 @@
+--- lilo/Makefile- Fri Dec 4 15:35:07 1998
++++ lilo/Makefile Wed Mar 17 01:04:07 1999
+@@ -24,7 +24,7 @@
+ # VARSETUP Enables use of variable-size setup segments.
+ # XL_SECS=n Support for extra large (non-standard) floppies.
+
+-CONFIG=-DIGNORECASE -DVARSETUP -DREWRITE_TABLE
++CONFIG=-DIGNORECASE -DVARSETUP -DREWRITE_TABLE -DLARGE_EBDA -DONE_SHOT
+
+ # End of configuration variables
+
+--- lilo/second.S- Fri Dec 4 15:20:07 1998
++++ lilo/second.S Wed Mar 17 01:03:53 1999
+@@ -830,9 +830,20 @@
+ call load1
+ seg es
+ mov CL_MAGIC_ADDR,#CL_MAGIC ! set magic number
++#ifndef LCF_LARGE_EBDA
+ seg es
+ mov word ptr CL_OFFSET,#PARMLINE+SECOND_SS
+ ! set parameter line offset
++#else
++ mov di,#0x8000
++ mov si,#PARMLINE
++ mov cx,#CL_LENGTH
++ rep
++ movsb
++ seg es
++ mov word ptr CL_OFFSET,#0x8000
++ ! set parameter line offset
++#endif
+ pop si ! restore SI
+ lodsw ! get flags bit map
+ mov bx,ax
+