summaryrefslogtreecommitdiff
path: root/packages/lighttpd/lighttpd_1.4.13.bb
diff options
context:
space:
mode:
authorOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-02-16 10:35:47 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2007-02-16 10:35:47 +0000
commit509c0496619a6f1583b1d0c380876ad618d453b2 (patch)
tree104a5c8347af3bc65c364df619489cdf3d339175 /packages/lighttpd/lighttpd_1.4.13.bb
parent4b905fee4e7d3ff9148d4716de92c9c3749fa17a (diff)
parenta16af27bc459438516b9c25ae55ec91d0f2cef03 (diff)
merge of '804173890b0c2381f9e13e27fce36c3396184943'
and '83e041bc8cc5227a7a45dd6a81c52b97ebcb893d'
Diffstat (limited to 'packages/lighttpd/lighttpd_1.4.13.bb')
-rw-r--r--packages/lighttpd/lighttpd_1.4.13.bb26
1 files changed, 15 insertions, 11 deletions
diff --git a/packages/lighttpd/lighttpd_1.4.13.bb b/packages/lighttpd/lighttpd_1.4.13.bb
index 9cb3d26425..504a129db8 100644
--- a/packages/lighttpd/lighttpd_1.4.13.bb
+++ b/packages/lighttpd/lighttpd_1.4.13.bb
@@ -2,12 +2,14 @@ DESCRIPTION = "Web server"
SECTION = "net"
DEPENDS = "sqlite3 libpcre libxml2"
LICENSE = "BSD"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://www.lighttpd.net/download/lighttpd-1.4.13.tar.gz \
- file://${PV}/configure.in.patch;patch=1;pnum=2 \
- file://${PV}/src-server.c.patch;patch=1;pnum=1 \
- file://conf/etc "
+ file://configure.in.patch;patch=1 \
+ file://src-server.c.patch;patch=1 \
+ file://index.html \
+ file://lighttpd.conf \
+ file://lighttpd"
EXTRA_OECONF="--without-bzip2 \
--without-ldap \
@@ -20,18 +22,20 @@ EXTRA_OECONF="--without-bzip2 \
--disable-nls \
--disable-static"
-inherit autotools pkgconfig
+inherit autotools pkgconfig update-rc.d
-do_install_append() {
- cp -R ${WORKDIR}/conf/etc ${D}/etc
- rm -fR ${D}/etc/.svn
- rm -fR ${D}/etc/init.d/.svn
+INITSCRIPT_NAME = "lighttpd"
+INITSCRIPT_PARAMS = "defaults 70"
- chmod -R 755 ${D}/etc
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
+ install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/index.html ${D}/www/pages/
}
do_stage() {
autotools_stage_all
}
-FILES_${PN} += "${libdir}/mod_*.so /etc"
+FILES_${PN} += "${libdir}/mod_*.so ${sysconfdir} /www"