summaryrefslogtreecommitdiff
path: root/packages/lighttpd/lighttpd_1.4.13.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-02-15 12:32:49 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-02-15 12:32:49 +0000
commit27d365f276a934de64c2b54f961007668996970e (patch)
treeff3bf1082a21d690a616b8d64c0460aab026123a /packages/lighttpd/lighttpd_1.4.13.bb
parentb36aaa0e6238f8a966561edb444f4661e84b801d (diff)
lighttpd: lot of bugfixes
- forced PCRE detection so it is linked in - cleaned directory structure - added /www/ dirs needed - added empty homepage - fixed initscript
Diffstat (limited to 'packages/lighttpd/lighttpd_1.4.13.bb')
-rw-r--r--packages/lighttpd/lighttpd_1.4.13.bb26
1 files changed, 15 insertions, 11 deletions
diff --git a/packages/lighttpd/lighttpd_1.4.13.bb b/packages/lighttpd/lighttpd_1.4.13.bb
index 9cb3d26425..504a129db8 100644
--- a/packages/lighttpd/lighttpd_1.4.13.bb
+++ b/packages/lighttpd/lighttpd_1.4.13.bb
@@ -2,12 +2,14 @@ DESCRIPTION = "Web server"
SECTION = "net"
DEPENDS = "sqlite3 libpcre libxml2"
LICENSE = "BSD"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://www.lighttpd.net/download/lighttpd-1.4.13.tar.gz \
- file://${PV}/configure.in.patch;patch=1;pnum=2 \
- file://${PV}/src-server.c.patch;patch=1;pnum=1 \
- file://conf/etc "
+ file://configure.in.patch;patch=1 \
+ file://src-server.c.patch;patch=1 \
+ file://index.html \
+ file://lighttpd.conf \
+ file://lighttpd"
EXTRA_OECONF="--without-bzip2 \
--without-ldap \
@@ -20,18 +22,20 @@ EXTRA_OECONF="--without-bzip2 \
--disable-nls \
--disable-static"
-inherit autotools pkgconfig
+inherit autotools pkgconfig update-rc.d
-do_install_append() {
- cp -R ${WORKDIR}/conf/etc ${D}/etc
- rm -fR ${D}/etc/.svn
- rm -fR ${D}/etc/init.d/.svn
+INITSCRIPT_NAME = "lighttpd"
+INITSCRIPT_PARAMS = "defaults 70"
- chmod -R 755 ${D}/etc
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
+ install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/index.html ${D}/www/pages/
}
do_stage() {
autotools_stage_all
}
-FILES_${PN} += "${libdir}/mod_*.so /etc"
+FILES_${PN} += "${libdir}/mod_*.so ${sysconfdir} /www"