summaryrefslogtreecommitdiff
path: root/packages/lighttpd/1.4.13
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2006-12-07 23:20:12 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-07 23:20:12 +0000
commit3a89ce65aad826ad0a92c90de2fc81dcc72ddc36 (patch)
treea45286afb3d91d1b557af4dfe792bc015ff879f5 /packages/lighttpd/1.4.13
parent19ae1d46043ee8624db78f552bdd854ff3c09390 (diff)
lighttpd: add 1.4.13, closes #1662
Diffstat (limited to 'packages/lighttpd/1.4.13')
-rw-r--r--packages/lighttpd/1.4.13/.mtn2git_empty0
-rw-r--r--packages/lighttpd/1.4.13/configure.in.patch28
-rw-r--r--packages/lighttpd/1.4.13/src-server.c.patch22
3 files changed, 50 insertions, 0 deletions
diff --git a/packages/lighttpd/1.4.13/.mtn2git_empty b/packages/lighttpd/1.4.13/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/lighttpd/1.4.13/.mtn2git_empty
diff --git a/packages/lighttpd/1.4.13/configure.in.patch b/packages/lighttpd/1.4.13/configure.in.patch
new file mode 100644
index 0000000000..f4db64d4fe
--- /dev/null
+++ b/packages/lighttpd/1.4.13/configure.in.patch
@@ -0,0 +1,28 @@
+Index: lighttpd-1.4.13-r0/lighttpd-1.4.13/configure.in
+===================================================================
+--- lighttpd-1.4.13-r0.orig/lighttpd-1.4.13/configure.in 2006-10-09 18:19:34.000000000 +0200
++++ lighttpd-1.4.13-r0/lighttpd-1.4.13/configure.in 2006-12-07 22:31:52.000000000 +0100
+@@ -250,23 +250,9 @@
+ [WITH_PCRE=$withval],[WITH_PCRE=yes])
+ AC_MSG_RESULT([$WITH_PCRE])
+
+-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
+- AC_PATH_PROG(PCRECONFIG, pcre-config)
+
+- if test x"$PCRECONFIG" != x; then
+- PCRE_LIB=`$PCRECONFIG --libs`
+- CPPFLAGS="$CPPFLAGS `$PCRECONFIG --cflags`"
+- OLDLIBS="$LIBS"
+- LIBS="$LIBS $PCRE_LIB"
+- AC_CHECK_LIB(pcre, pcre_compile, [
+- AC_CHECK_HEADERS([pcre.h], [
+ AC_DEFINE([HAVE_LIBPCRE], [1], [libpcre])
+ AC_DEFINE([HAVE_PCRE_H], [1])
+- ])
+- ])
+- LIBS="$OLDLIBS"
+- fi
+-fi
+
+ AC_SUBST(PCRE_LIB)
+
diff --git a/packages/lighttpd/1.4.13/src-server.c.patch b/packages/lighttpd/1.4.13/src-server.c.patch
new file mode 100644
index 0000000000..6ca0c9ea40
--- /dev/null
+++ b/packages/lighttpd/1.4.13/src-server.c.patch
@@ -0,0 +1,22 @@
+--- lighttpd/src/server.c.orig 2006-03-04 09:12:17.000000000 -0800
++++ lighttpd/src/server.c 2006-07-11 09:16:28.000000000 -0700
+@@ -1174,8 +1174,8 @@
+ if (srv->sockets_disabled) {
+ /* our server sockets are disabled, why ? */
+
+- if ((srv->cur_fds + srv->want_fds < srv->max_fds * 0.8) && /* we have enough unused fds */
+- (srv->conns->used < srv->max_conns * 0.9) &&
++ if ((srv->cur_fds + srv->want_fds < srv->max_fds * 8 / 10) && /* we have enough unused fds */
++ (srv->conns->used < srv->max_conns * 9 / 10) &&
+ (0 == graceful_shutdown)) {
+ for (i = 0; i < srv->srv_sockets.used; i++) {
+ server_socket *srv_socket = srv->srv_sockets.ptr[i];
+@@ -1187,7 +1187,7 @@
+ srv->sockets_disabled = 0;
+ }
+ } else {
+- if ((srv->cur_fds + srv->want_fds > srv->max_fds * 0.9) || /* out of fds */
++ if ((srv->cur_fds + srv->want_fds > srv->max_fds * 9 / 10) || /* out of fds */
+ (srv->conns->used > srv->max_conns) || /* out of connections */
+ (graceful_shutdown)) { /* graceful_shutdown */
+