summaryrefslogtreecommitdiff
path: root/packages/libxslt/libxslt_1.1.12.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2006-07-12 13:49:19 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-12 13:49:19 +0000
commit2fb7dbea15a9defe06eff9e3d63a7ea342e71448 (patch)
tree24a350d526384edeed920eb89be58ba657009d41 /packages/libxslt/libxslt_1.1.12.bb
parentd0bce41e1b2c5124ed85aac04d715ca147a16632 (diff)
parent060802a060579c858748b6ef5f9075c449a3c861 (diff)
merge of 5180d45d06f92e034b4c024f4f52e16d157aa0d9
and 596b10cd24c63dccc9c168ee841040c9f8615e50
Diffstat (limited to 'packages/libxslt/libxslt_1.1.12.bb')
-rw-r--r--packages/libxslt/libxslt_1.1.12.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/libxslt/libxslt_1.1.12.bb b/packages/libxslt/libxslt_1.1.12.bb
new file mode 100644
index 0000000000..b98a3c54e8
--- /dev/null
+++ b/packages/libxslt/libxslt_1.1.12.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2"
+LICENSE = "MIT"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug"
+
+xsltheaders = "attributes.h documents.h extensions.h extra.h functions.h imports.h \
+ keys.h namespaces.h numbersInternals.h pattern.h preproc.h security.h \
+ templates.h transform.h variables.h xslt.h xsltInternals.h xsltconfig.h \
+ xsltexports.h xsltutils.h"
+exsltheaders = "exslt.h exsltconfig.h exsltexports.h"
+
+do_stage () {
+ oe_libinstall -C libxslt -so -a libxslt ${STAGING_LIBDIR}
+ oe_libinstall -C libexslt -so -a libexslt ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/libxslt
+ for i in ${xsltheaders}; do
+ install -m 0644 ${S}/libxslt/$i ${STAGING_INCDIR}/libxslt/$i
+ done
+ mkdir -p ${STAGING_INCDIR}/libexslt
+ for i in ${exsltheaders}; do
+ install -m 0644 ${S}/libexslt/$i ${STAGING_INCDIR}/libexslt/$i
+ done
+
+ cat xslt-config | sed -e "s,^prefix=.*,prefix=${STAGING_BINDIR}/..," \
+ -e "s,^exec_prefix=.*,exec_prefix=${STAGING_BINDIR}/..," \
+ -e "s,^includedir=.*,includedir=${STAGING_INCDIR}," \
+ -e "s,^libdir=.*,libdir=${STAGING_LIBDIR}," > ${STAGING_BINDIR}/xslt-config
+ chmod a+rx ${STAGING_BINDIR}/xslt-config
+ install -m 0644 libxslt.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES = "${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"