summaryrefslogtreecommitdiff
path: root/packages/libxml/libxml2-native_2.6.29.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-18 13:37:29 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-18 13:37:29 +0000
commiteb1bc6e2d48c04db954aa69f738109873dcbbcd3 (patch)
tree328e9933d0c15cc3245f7f9aab4106bc0593ccdb /packages/libxml/libxml2-native_2.6.29.bb
parent5ae14e052c68c2666a1152e33ddb227455913766 (diff)
libxml2-native: catch up with python2.5 update
Diffstat (limited to 'packages/libxml/libxml2-native_2.6.29.bb')
-rw-r--r--packages/libxml/libxml2-native_2.6.29.bb19
1 files changed, 13 insertions, 6 deletions
diff --git a/packages/libxml/libxml2-native_2.6.29.bb b/packages/libxml/libxml2-native_2.6.29.bb
index fc9c3697de..5672792db3 100644
--- a/packages/libxml/libxml2-native_2.6.29.bb
+++ b/packages/libxml/libxml2-native_2.6.29.bb
@@ -1,16 +1,23 @@
DESCRIPTION = "GNOME XML library"
-PR = "r1"
-
-SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
-
DEPENDS = "python-native"
-
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+PR = "r3"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz"
S = "${WORKDIR}/libxml2-${PV}"
inherit autotools native pkgconfig
-EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/python2.4 --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
+def libxml2_native_python_dir(d):
+ import os, bb
+ staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
+ if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
+ if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
+ if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
+ raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
+
+EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/${@libxml2_native_python_dir(d)} \
+ --without-debug --without-legacy --without-catalog --without-docbook --with-c14n"
do_stage () {
oe_runmake install