summaryrefslogtreecommitdiff
path: root/packages/libvorbis
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-12-19 10:02:27 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-12-19 10:02:27 +0000
commitc7e33ecf737e93f9ecec2cc609064bfd593f2b61 (patch)
treea657ac69b5e38e1887286933e9ae748e2267b27b /packages/libvorbis
parentef93660d2fbd162ca59457c96d7e1cea9cd8b907 (diff)
parentf871fead79da276cf252c7a9ab1b33e33119b009 (diff)
merge of '074f227db84b62ec3c531c61efcd62fc6b429dc3'
and '5af64e0f29377b9ebbc655af469dd70d6a2f6dfb'
Diffstat (limited to 'packages/libvorbis')
-rw-r--r--packages/libvorbis/libvorbis_1.2.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/libvorbis/libvorbis_1.2.0.bb b/packages/libvorbis/libvorbis_1.2.0.bb
new file mode 100644
index 0000000000..79b79e8f49
--- /dev/null
+++ b/packages/libvorbis/libvorbis_1.2.0.bb
@@ -0,0 +1,30 @@
+SECTION = "libs"
+DEPENDS = "libogg"
+DESCRIPTION = "Ogg Vorbis is a high-quality lossy audio codec \
+that is free of intellectual property restrictions. libvorbis \
+is the main vorbis codec library."
+LICENSE = "BSD"
+
+SRC_URI = "http://downloads.xiph.org/releases/vorbis/libvorbis-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+# vorbisfile.c reveals a problem in the gcc register spilling for the
+# thumb instruction set...
+FULL_OPTIMIZATION_thumb = "-O0"
+
+EXTRA_OECONF = "--with-ogg-libraries=${STAGING_LIBDIR} \
+ --with-ogg-includes=${STAGING_INCDIR}"
+
+do_stage () {
+ oe_libinstall -a -so -C lib libvorbis ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C lib libvorbisfile ${STAGING_LIBDIR}
+ oe_libinstall -a -so -C lib libvorbisenc ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/vorbis
+ install -m 0644 include/vorbis/vorbisenc.h \
+ include/vorbis/vorbisfile.h \
+ include/vorbis/codec.h ${STAGING_INCDIR}/vorbis/
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 vorbis.m4 ${STAGING_DATADIR}/aclocal/
+}