summaryrefslogtreecommitdiff
path: root/packages/libvncserver/libvncserver_0.8.2.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-08-07 20:42:01 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-08-07 20:42:01 +0000
commitcf19e0b8978e4e57ec521ce4ca0ef3cea634befa (patch)
tree898b0310945402cc9ce7ee619e45957f0ba74cc1 /packages/libvncserver/libvncserver_0.8.2.bb
parentb4a3c084935bafbbdb3e5093c4584e17410f7b52 (diff)
libvncserver add 0.8.2, remove older ones.
patch based on bug #1281, thanks gfellerpatrik@gmx.net
Diffstat (limited to 'packages/libvncserver/libvncserver_0.8.2.bb')
-rw-r--r--packages/libvncserver/libvncserver_0.8.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/libvncserver/libvncserver_0.8.2.bb b/packages/libvncserver/libvncserver_0.8.2.bb
new file mode 100644
index 0000000000..480a888745
--- /dev/null
+++ b/packages/libvncserver/libvncserver_0.8.2.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "A library to support implementations of RDP/VNC servers"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://sourceforge.net/projects/libvncserver"
+AUTHOR = "Johannes Schindelin <dscho@users.sourceforge.net>"
+MAINTAINER = "Patrik Gfeller <gfellerpatrik@gmx.net>"
+SECTION = "libs"
+PRIORITY = "optional"
+PROVIDES = "x11vnc"
+DEPENDS = "virtual/libsdl virtual/libx11 zlib jpeg"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/LibVNCServer-${PV}.tar.gz;md5sum=17a18e398af6c1730f72068022a152aa"
+S = "${WORKDIR}/LibVNCServer-${PV}"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install_append() {
+ install -d ${D}${bindir}
+ install -m 0755 examples/storepasswd ${D}${bindir}
+ install -d ${D}${datadir}/fbvncserver/classes
+ install -m 0644 classes/index.vnc ${D}${datadir}/fbvncserver/classes/
+ install -m 0644 classes/VncViewer.jar ${D}${datadir}/fbvncserver/classes/
+}
+
+PACKAGES =+ "x11vnc libvncserver-storepasswd libvncserver-javaapplet"
+FILES_x11vnc = "${bindir}/x11vnc ${bindir}/LinuxVNC"
+FILES_libvncserver-storepasswd = "${bindir}/storepasswd"
+FILES_libvncserver-javaapplet = "${datadir}/fbvncserver/classes/index.vnc \
+ ${datadir}/fbvncserver/classes/VncViewer.jar"