summaryrefslogtreecommitdiff
path: root/packages/libusb/libusb1_1.0.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-12-16 21:53:18 +0100
committerKoen Kooi <koen@openembedded.org>2008-12-16 21:53:18 +0100
commit72b39d002c5f3a9d4e6d70ba6abfe85d4ea69fed (patch)
tree059bf4f586fae7a36f031cf7aee2fdde83d5278e /packages/libusb/libusb1_1.0.0.bb
parentc6c9ec01e824d26898f7276ffb8c5ba6e4a251c2 (diff)
libusb1: add 1.0.0 release, libusb is EOL
* the libusb site says "As of December 2008, libusb-1.0 is the current stable branch. Developers are encouraged to port their applications."
Diffstat (limited to 'packages/libusb/libusb1_1.0.0.bb')
-rw-r--r--packages/libusb/libusb1_1.0.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/libusb/libusb1_1.0.0.bb b/packages/libusb/libusb1_1.0.0.bb
new file mode 100644
index 0000000000..8450a7c946
--- /dev/null
+++ b/packages/libusb/libusb1_1.0.0.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "libusb is a library to provide userspace \
+access to USB devices."
+HOMEPAGE = "http://libusb.sf.net"
+SECTION = "libs"
+LICENSE = "LGPL"
+
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2 \
+"
+S = "${WORKDIR}/libusb-${PV}"
+
+inherit autotools pkgconfig binconfig lib_package
+
+PARALLEL_MAKE = ""
+EXTRA_OECONF = "--disable-build-docs"
+
+export CXXFLAGS += "-lstdc++ -I${STAGING_INCDIR}"
+
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "libusbpp"
+FILES_libusbpp = "${libdir}/libusbpp*.so.*"