summaryrefslogtreecommitdiff
path: root/packages/libusb/libusb1_0.9.2.bb
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2008-08-04 13:25:51 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-08-04 13:25:51 +0000
commit89b85eda60769fe941a2e64ea4d296617befc2af (patch)
treef10b4bb39f8fe221b930623636d1d4ce3b74b251 /packages/libusb/libusb1_0.9.2.bb
parent7efe32a8489c41f1fedb5bcca5b4ffdbc4713359 (diff)
parent810fb5eba6f2e57ce61b96361fb3445aac331ddf (diff)
merge of '59560bb699e5c53442482270321f0392e8772228'
and 'd7ac2578b689d01a8d9b17579781f0f7a6926ebd'
Diffstat (limited to 'packages/libusb/libusb1_0.9.2.bb')
-rw-r--r--packages/libusb/libusb1_0.9.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/libusb/libusb1_0.9.2.bb b/packages/libusb/libusb1_0.9.2.bb
new file mode 100644
index 0000000000..2c144f053d
--- /dev/null
+++ b/packages/libusb/libusb1_0.9.2.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "libusb is a library to provide userspace \
+access to USB devices."
+HOMEPAGE = "http://libusb.sf.net"
+SECTION = "libs"
+LICENSE = "LGPL"
+
+PR = "r0"
+
+SRC_URI = "\
+ ${SOURCEFORGE_MIRROR}/libusb/libusb-${PV}.tar.bz2 \
+ file://0.9.0-gcc3.4-compat-fix.patch;patch=1 \
+"
+S = "${WORKDIR}/libusb-${PV}"
+
+inherit autotools pkgconfig binconfig lib_package
+
+PARALLEL_MAKE = ""
+EXTRA_OECONF = "--disable-build-docs"
+
+export CXXFLAGS += "-lstdc++ -I${STAGING_INCDIR}"
+
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
+
+do_stage() {
+ autotools_stage_all
+}
+
+PACKAGES =+ "libusbpp"
+FILES_libusbpp = "${libdir}/libusbpp*.so.*"