summaryrefslogtreecommitdiff
path: root/packages/libtool/libtool_1.5.6.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-01-08 16:32:11 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-01-08 16:32:11 +0000
commit514c5a89d85f68e9d68de280aa437702e9afbe3c (patch)
tree6cb98bcc52dc942563b4e36011385d6107e1a74e /packages/libtool/libtool_1.5.6.bb
parentd30098ac944080b44061d7697079f36d1532bdcd (diff)
libtool 1.5.6: Re-introduce recipe.
Diffstat (limited to 'packages/libtool/libtool_1.5.6.bb')
-rw-r--r--packages/libtool/libtool_1.5.6.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/libtool/libtool_1.5.6.bb b/packages/libtool/libtool_1.5.6.bb
new file mode 100644
index 0000000000..2deb7df15c
--- /dev/null
+++ b/packages/libtool/libtool_1.5.6.bb
@@ -0,0 +1,38 @@
+# Exists for compatibility with certain distributions (e.g. Maemo).
+
+DESCRIPTION = "Generic library support script \
+This is GNU libtool, a generic library support script. Libtool hides \
+the complexity of generating special library types (such as shared \
+libraries) behind a consistent interface."
+HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
+LICENSE = "GPL"
+SECTION = "devel"
+PR = "r2"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
+ file://autotools.patch;patch=1"
+S = "${WORKDIR}/libtool-${PV}"
+
+PACKAGES = "libltdl libltdl-dbg libltdl-dev ${PN} ${PN}-doc"
+FILES_${PN} += "${datadir}/aclocal*"
+FILES_libltdl = "${libdir}/libltdl.so.*"
+FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
+FILES_libltdl-dbg = "${libdir}/.debug/"
+
+inherit autotools
+
+EXTRA_AUTORECONF = "--exclude=libtoolize"
+
+do_configure () {
+ find ${S} -name acinclude.m4 | for m4 in `cat`; do
+ cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
+ done
+ autotools_do_configure
+}
+
+do_stage () {
+ oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
+ install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
+}