summaryrefslogtreecommitdiff
path: root/packages/libtool/libtool_1.5.22.bb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2007-05-05 20:35:20 +0000
committerPhilip Balister <philip@balister.org>2007-05-05 20:35:20 +0000
commitd26de2c423b2f4d3454eac2f952f127d426e5839 (patch)
tree4de80c49d679832241bb40d270e09a62c984a4cd /packages/libtool/libtool_1.5.22.bb
parent97869ccc886d6153dccea808949d619f37eeebfe (diff)
libtool : Add bb files for libtool-1.5.22. DEFAULT_PREFERENCE set to -1
until these are better tested.
Diffstat (limited to 'packages/libtool/libtool_1.5.22.bb')
-rw-r--r--packages/libtool/libtool_1.5.22.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/packages/libtool/libtool_1.5.22.bb b/packages/libtool/libtool_1.5.22.bb
new file mode 100644
index 0000000000..d470d30cda
--- /dev/null
+++ b/packages/libtool/libtool_1.5.22.bb
@@ -0,0 +1,37 @@
+DEFAULT_PREFERENCE = "-1"
+
+DESCRIPTION = "Generic library support script \
+This is GNU libtool, a generic library support script. Libtool hides \
+the complexity of generating special library types (such as shared \
+libraries) behind a consistent interface."
+HOMEPAGE = "http://www.gnu.org/software/libtool/libtool.html"
+LICENSE = "GPL"
+SECTION = "devel"
+PR = "r1"
+
+SRC_URI = "${GNU_MIRROR}/libtool/libtool-${PV}.tar.gz \
+ file://autotools.patch;patch=1 \
+ file://uclibc.patch;patch=1"
+# file://3figures.patch;patch=1"
+S = "${WORKDIR}/libtool-${PV}"
+
+PACKAGES = "libltdl libltdl-dev ${PN}"
+FILES_${PN} += "${datadir}/aclocal*"
+FILES_libltdl = "${libdir}/libltdl.so.*"
+FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
+
+inherit autotools
+
+EXTRA_AUTORECONF = "--exclude=libtoolize"
+
+do_configure () {
+ find ${S} -name acinclude.m4 | for m4 in `cat`; do
+ cat ${S}/libtool.m4 ${S}/ltdl.m4 > $m4
+ done
+ autotools_do_configure
+}
+
+do_stage () {
+ oe_libinstall -a -so -C libltdl libltdl ${STAGING_LIBDIR}
+ install -m 0644 libltdl/ltdl.h ${STAGING_INCDIR}/
+}