summaryrefslogtreecommitdiff
path: root/packages/libssh
diff options
context:
space:
mode:
authorLynn Lin <lynn.lin@avocent.com>2009-02-14 14:11:58 -0800
committerKhem Raj <raj.khem@gmail.com>2009-02-14 14:11:58 -0800
commit51fb74e2857910bc85c2dcf88b15d2e2707b743e (patch)
treec92edf47e7e3781bf23d44b0ed4733b68881d786 /packages/libssh
parentdb98888b0fdec6cc0fce147088ad10eef34f1bc5 (diff)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
libssh_0.2.bb: New recipe libssh_0.11.bb: Reduce priority so that libssh_0.2.bb can be picked up. * Some how oe_runmake called with make -j4 did not work for me thats why I used non parallel make.
Diffstat (limited to 'packages/libssh')
-rw-r--r--packages/libssh/files/libssh_libdir_fix.patch13
-rw-r--r--packages/libssh/libssh_0.11.bb2
-rw-r--r--packages/libssh/libssh_0.2.bb28
3 files changed, 43 insertions, 0 deletions
diff --git a/packages/libssh/files/libssh_libdir_fix.patch b/packages/libssh/files/libssh_libdir_fix.patch
new file mode 100644
index 0000000000..a9fcce79e3
--- /dev/null
+++ b/packages/libssh/files/libssh_libdir_fix.patch
@@ -0,0 +1,13 @@
+diff -NurpP --minimal libssh-0.2/libssh/Makefile.in libssh-0.2-libdir/libssh/Makefile.in
+--- libssh-0.2/libssh/Makefile.in 2006-12-29 23:03:59.000000000 +0800
++++ libssh-0.2-libdir/libssh/Makefile.in 2008-10-13 10:04:13.000000000 +0800
+@@ -15,7 +15,7 @@ exec_prefix = @exec_prefix@
+ bindir = $(exec_prefix)/bin
+ incldir= $(prefix)/include
+ infodir = $(prefix)/info
+-libdir = $(prefix)/lib/
++libdir = $(prefix)/lib
+ mandir = $(prefix)/man/man1
+
+ CC = @CC@
+
diff --git a/packages/libssh/libssh_0.11.bb b/packages/libssh/libssh_0.11.bb
index ab6949f409..833567ebb0 100644
--- a/packages/libssh/libssh_0.11.bb
+++ b/packages/libssh/libssh_0.11.bb
@@ -6,6 +6,8 @@ includes SFTP support, and a sample SSH client is provided."
DEPENDS = "openssl"
LICENSE = "LGPL"
+DEFAULT_PREFERENCE="-1"
+
SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz"
inherit autotools
diff --git a/packages/libssh/libssh_0.2.bb b/packages/libssh/libssh_0.2.bb
new file mode 100644
index 0000000000..b776094018
--- /dev/null
+++ b/packages/libssh/libssh_0.2.bb
@@ -0,0 +1,28 @@
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "The SSH library is a C library to authenticate in a \
+simple manner to one or more SSH servers. The goal of this project \
+is to provide a library much simpler to use than OpenSSHs one. It \
+includes SFTP support, and a sample SSH client is provided."
+
+HOMEPAGE = "http://0xbadc0de.be/wiki/libssh:libssh"
+LICENSE = "LGPL"
+SECTION = "libs"
+DEPENDS = "openssl"
+SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz \
+ file://libssh_libdir_fix.patch;patch=1 \
+ "
+inherit autotools
+
+EXTRA_OECONF = "--cache-file=${S}/config.cache"
+do_compile () {
+ oenote make "$@"
+ make "$@" || die "oe_runmake failed"
+}
+do_stage () {
+ install -d ${STAGING_INCDIR}/libssh
+ for i in crypto.h libssh.h sftp.h ssh2.h; do
+ install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
+ done
+ oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
+}