summaryrefslogtreecommitdiff
path: root/packages/libssh/libssh_0.11.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-07-28 17:08:23 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-07-28 17:08:23 +0000
commitfd78ba9fa8e711dcc99f29257b1c7bcde8026997 (patch)
tree4d1bd1b9578d03f939added0c7cbb6f43fe53e43 /packages/libssh/libssh_0.11.bb
parent2e955b45d99552699cded33d990df885fe6dc94b (diff)
parent89cf3c3129957d5f249793f2aecfdf3885aed9ba (diff)
merge of 65ba11a9774e6d79d6e8cf86b9aa4280fb5092e4
and adeae08e534b3e3695bc45e3b6413729fe210c7d
Diffstat (limited to 'packages/libssh/libssh_0.11.bb')
-rw-r--r--packages/libssh/libssh_0.11.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/libssh/libssh_0.11.bb b/packages/libssh/libssh_0.11.bb
new file mode 100644
index 0000000000..ab6949f409
--- /dev/null
+++ b/packages/libssh/libssh_0.11.bb
@@ -0,0 +1,33 @@
+SECTION = "libs"
+DESCRIPTION = "The SSH library is a C library to authenticate in a \
+simple manner to one or more SSH servers. The goal of this project \
+is to provide a library much simpler to use than OpenSSHs one. It \
+includes SFTP support, and a sample SSH client is provided."
+DEPENDS = "openssl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz"
+
+inherit autotools
+
+EXTRA_OECONF = "--cache-file=${S}/config.cache"
+
+do_stage () {
+ set -x
+ install -d ${STAGING_INCDIR}/libssh
+ for i in crypto.h libssh.h sftp.h ssh2.h; do
+ install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
+ done
+ oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake "prefix=${D}${prefix}" \
+ "exec_prefix=${D}${exec_prefix}" \
+ "bindir=${D}${bindir}" \
+ "incldir=${D}${includedir}" \
+ "infodir=${D}${infodir}" \
+ "mandir=${D}${mandir}/man1" \
+ "libdir=${D}${libdir}" \
+ install
+}