summaryrefslogtreecommitdiff
path: root/packages/libsdl/libsdl-native_1.2.11.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-10-20 11:46:21 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-10-20 11:46:21 +0000
commit8a21ca4868f6fc425f4da7d0f51bfce13b1cd16d (patch)
treef5085792931422118b2e6e44eea427dd932d3cdf /packages/libsdl/libsdl-native_1.2.11.bb
parent86ba355716b28fd055a879f1c9a786b8aa2e2c19 (diff)
add libsdl-native 1.2.11 - this one compiles with gcc4
Diffstat (limited to 'packages/libsdl/libsdl-native_1.2.11.bb')
-rw-r--r--packages/libsdl/libsdl-native_1.2.11.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/libsdl/libsdl-native_1.2.11.bb b/packages/libsdl/libsdl-native_1.2.11.bb
new file mode 100644
index 0000000000..298426a04c
--- /dev/null
+++ b/packages/libsdl/libsdl-native_1.2.11.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Simple DirectMedia Layer - native Edition"
+HOMEPAGE = "http://www.libsdl.org"
+SECTION = "libs"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "http://www.libsdl.org/release/SDL-${PV}.tar.gz \
+ file://acinclude.m4"
+S = "${WORKDIR}/SDL-${PV}"
+
+inherit autotools pkgconfig native
+
+EXTRA_OECONF = "--disable-debug --disable-cdrom --enable-threads --enable-timers --enable-endian \
+ --enable-file --disable-oss --disable-alsa --disable-esd --disable-arts \
+ --disable-diskaudio --disable-nas --disable-esd-shared --disable-esdtest \
+ --disable-mintaudio --disable-nasm --disable-video-x11 --disable-video-dga \
+ --disable-video-fbcon --disable-video-directfb --disable-video-ps2gs \
+ --disable-video-xbios --disable-video-gem --disable-video-dummy \
+ --disable-video-opengl --enable-input-events --enable-pthreads \
+ --disable-video-picogui --disable-video-qtopia --enable-dlopen"
+
+do_configure() {
+ rm -f ${S}/acinclude.m4
+ cp ${WORKDIR}/acinclude.m4 ${S}/
+ gnu-configize
+ oe_runconf
+ cd ${S}
+ # prevent libtool from linking libs against libstdc++, libgcc, ...
+ cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
+ mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
+}
+
+do_stage() {
+ autotools_stage_all
+ install -m 0644 build/libSDLmain.a ${STAGING_LIBDIR}
+}