summaryrefslogtreecommitdiff
path: root/packages/libpcre/libpcre_7.6.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2008-04-06 23:36:07 +0000
committerStanislav Brabec <utx@penguin.cz>2008-04-06 23:36:07 +0000
commit94f7efd4bc93610e880fbffad23b94462d2fc449 (patch)
tree428c1a021b71350f5da0685c0450f6392d5eed54 /packages/libpcre/libpcre_7.6.bb
parentfbca01e0fc7d470346573de02b3f0e7dbf8dd6a4 (diff)
Update of libpcre to version 7.6:
* new major branch, new features * required for new goffice * uses automake, native-rpath-link.patch is no more needed * enabled UTF-8 for target build (required for new goffice)
Diffstat (limited to 'packages/libpcre/libpcre_7.6.bb')
-rw-r--r--packages/libpcre/libpcre_7.6.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/libpcre/libpcre_7.6.bb b/packages/libpcre/libpcre_7.6.bb
new file mode 100644
index 0000000000..3171e10e68
--- /dev/null
+++ b/packages/libpcre/libpcre_7.6.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "Perl-compatible regular expression library. PCRE has its own native \
+API, but a set of 'wrapper' functions that are based on the POSIX API \
+are also supplied in the library libpcreposix. Note that this just \
+provides a POSIX calling interface to PCRE; the regular expressions \
+themselves still follow Perl syntax and semantics. The header file for \
+the POSIX-style functions is called pcreposix.h."
+SECTION = "devel"
+PR = "r1"
+LICENSE = "BSD"
+SRC_URI = "${SOURCEFORGE_MIRROR}/pcre/pcre-${PV}.tar.bz2 \
+ file://pcre-cross.patch;patch=1"
+S = "${WORKDIR}/pcre-${PV}"
+
+PROVIDES = "pcre"
+
+inherit autotools binconfig
+
+PARALLEL_MAKE = ""
+
+LEAD_SONAME = "libpcre.so"
+CFLAGS_append = " -D_REENTRANT"
+EXTRA_OECONF = " --with-link-size=2 --enable-newline-is-lf --with-match-limit=10000000 --enable-rebuild-chartables --enable-utf8"
+
+do_compile () {
+ # stop libtool from trying to link with host libraries - fix from #33
+ # this resolve build problem on amd64 - #1015
+ sed -i 's:-L\$:-L${STAGING_LIBDIR} -L\$:' ${S}/${TARGET_SYS}-libtool
+
+ # The generation of dftables can lead to timestamp problems with ccache
+ # because the generated config.h seems newer. It is sufficient to ensure that the
+ # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
+ # only used for this).
+ oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC} -L${S}/lib"
+}
+
+do_stage () {
+ oe_libinstall -a -so libpcre ${STAGING_LIBDIR}
+ oe_libinstall -a -so libpcreposix ${STAGING_LIBDIR}
+ install -m 0644 pcre.h ${STAGING_INCDIR}/
+ install -m 0644 pcreposix.h ${STAGING_INCDIR}/
+ install -d ${STAGING_BINDIR_NATIVE}
+ install -m 0755 ${S}/dftables ${STAGING_BINDIR_NATIVE}/
+}
+
+FILES_${PN} = "${libdir}/lib*.so.*"
+FILES_${PN}-dev += "${bindir}/*"