summaryrefslogtreecommitdiff
path: root/packages/libpcre/files
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2008-04-06 23:36:07 +0000
committerStanislav Brabec <utx@penguin.cz>2008-04-06 23:36:07 +0000
commit94f7efd4bc93610e880fbffad23b94462d2fc449 (patch)
tree428c1a021b71350f5da0685c0450f6392d5eed54 /packages/libpcre/files
parentfbca01e0fc7d470346573de02b3f0e7dbf8dd6a4 (diff)
Update of libpcre to version 7.6:
* new major branch, new features * required for new goffice * uses automake, native-rpath-link.patch is no more needed * enabled UTF-8 for target build (required for new goffice)
Diffstat (limited to 'packages/libpcre/files')
-rw-r--r--packages/libpcre/files/native-rpath-link.patch19
-rw-r--r--packages/libpcre/files/pcre-cross.patch25
2 files changed, 25 insertions, 19 deletions
diff --git a/packages/libpcre/files/native-rpath-link.patch b/packages/libpcre/files/native-rpath-link.patch
deleted file mode 100644
index 69de2bea64..0000000000
--- a/packages/libpcre/files/native-rpath-link.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Index: pcre-4.4/Makefile.in
-===================================================================
---- pcre-4.4.orig/Makefile.in 2003-08-21 11:43:07.000000000 +0100
-+++ pcre-4.4/Makefile.in 2008-03-19 10:34:08.000000000 +0000
-@@ -107,12 +107,12 @@
-
- libpcre.la: $(OBJ)
- -rm -f libpcre.la
-- $(LINKLIB) -rpath $(LIBDIR) -version-info \
-+ $(LINKLIB) -rpath $(LIBDIR) -L$(LIBDIR) -version-info \
- '$(PCRELIBVERSION)' -o libpcre.la $(LOBJ)
-
- libpcreposix.la: pcreposix.@OBJEXT@
- -rm -f libpcreposix.la
-- $(LINKLIB) -rpath $(LIBDIR) libpcre.la -version-info \
-+ $(LINKLIB) -rpath $(LIBDIR) -L$(LIBDIR) libpcre.la -version-info \
- '$(PCREPOSIXLIBVERSION)' -o libpcreposix.la pcreposix.lo
-
- pcre.@OBJEXT@: $(top_srcdir)/chartables.c $(top_srcdir)/pcre.c \
diff --git a/packages/libpcre/files/pcre-cross.patch b/packages/libpcre/files/pcre-cross.patch
new file mode 100644
index 0000000000..0626fb347a
--- /dev/null
+++ b/packages/libpcre/files/pcre-cross.patch
@@ -0,0 +1,25 @@
+To be upstreamable, this patch requires check for *_FOR_BUILD, otherwise
+it needs to pass special variables.
+
+It would be nice to implement per-target compiler specification to
+automake, as it is done for linker.
+
+Even better it would be nice to implement native build time targets in
+automake.
+
+Index: pcre-7.6/Makefile.am
+===================================================================
+--- pcre-7.6.orig/Makefile.am 2008-01-23 17:58:28.000000000 +0000
++++ pcre-7.6/Makefile.am 2008-04-03 22:32:00.000000000 +0000
+@@ -147,6 +147,11 @@
+
+ noinst_PROGRAMS += dftables
+ dftables_SOURCES = dftables.c
++dftables_LINK = $(LINK_FOR_BUILD) -o $@
++dftables_LDFLAGS = $(LDFLAGS_FOR_BUILD)
++
++dftables.o: $(srcdir)/dftables.c
++ $(CC_FOR_BUILD) -c $(CFLAGS_FOR_BUILD) -o $@ $(srcdir)/dftables.c
+
+ pcre_chartables.c: dftables$(EXEEXT)
+ ./dftables$(EXEEXT) $@