summaryrefslogtreecommitdiff
path: root/packages/libnl
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2006-08-24 16:51:15 +0000
committerJustin Patrin <papercrane@gmail.com>2006-08-24 16:51:15 +0000
commit8c26a0765131ba59294b560a305a8ccc88820fad (patch)
treec5e50771b4a42edd0363674c69879523be2ff268 /packages/libnl
parent47f3e7555619a8858fc5bf9bc5c81524e92d9010 (diff)
parentb9839e8807ed8dacc3052294018433e41d2aeeda (diff)
merge of '2727f9135b6cab138d8484eaefc8eda4afcfbc41'
and '9bd8fd454a7f2f34cfe7e3a27b1f18aaab798336'
Diffstat (limited to 'packages/libnl')
-rw-r--r--packages/libnl/.mtn2git_empty0
-rw-r--r--packages/libnl/files/.mtn2git_empty0
-rw-r--r--packages/libnl/files/local-includes.patch11
-rw-r--r--packages/libnl/libnl_1.0-pre6.bb25
4 files changed, 36 insertions, 0 deletions
diff --git a/packages/libnl/.mtn2git_empty b/packages/libnl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libnl/.mtn2git_empty
diff --git a/packages/libnl/files/.mtn2git_empty b/packages/libnl/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libnl/files/.mtn2git_empty
diff --git a/packages/libnl/files/local-includes.patch b/packages/libnl/files/local-includes.patch
new file mode 100644
index 0000000000..5af463004b
--- /dev/null
+++ b/packages/libnl/files/local-includes.patch
@@ -0,0 +1,11 @@
+--- libnl-1.0-pre6/Makefile.opts.in.orig 2006-08-24 14:57:42.000000000 +0200
++++ libnl-1.0-pre6/Makefile.opts.in 2006-08-24 14:58:20.000000000 +0200
+@@ -10,7 +10,7 @@
+ #
+
+ CC := @CC@
+-CFLAGS := @CFLAGS@
++CFLAGS := -I./include -I. -I../include @CFLAGS@
+ LDFLAGS := @LDFLAGS@
+ CPPFLAGS := @CPPFLAGS@
+ PACKAGE_NAME := @PACKAGE_NAME@
diff --git a/packages/libnl/libnl_1.0-pre6.bb b/packages/libnl/libnl_1.0-pre6.bb
new file mode 100644
index 0000000000..3851c5687d
--- /dev/null
+++ b/packages/libnl/libnl_1.0-pre6.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "libnl is a library for applications dealing with netlink sockets"
+SECTION = "libs/network"
+LICENSE = "LGPL"
+HOMEPAGE = "http://people.suug.ch/~tgr/libnl/"
+MAINTAINER = "Milan Plzik <mmp@handhelds.org>"
+PRIORITY = "optional"
+DEPENDS = "glibc"
+
+inherit autotools pkgconfig gpe
+
+SRC_URI= "http://people.suug.ch/~tgr/libnl/files/${P}.tar.gz \
+ file://local-includes.patch;patch=1"
+
+do_install() {
+ oe_runmake prefix=${prefix} DESTDIR=${D} install
+}
+
+do_stage () {
+ autotools_stage_all prefix=${prefix}
+}
+
+do_install () {
+ oe_runmake prefix=${prefix} DESTDIR=${D} install
+}
+