summaryrefslogtreecommitdiff
path: root/packages/libnet/libnet_1.1.2.1.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-11-18 08:19:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-18 08:19:15 +0000
commitc7ced19dc6616e09f8c45d0c539339fbe17a9caf (patch)
tree16c9a3b2860668671b9bad054f479dfe478465db /packages/libnet/libnet_1.1.2.1.bb
parentcce6287a6f4589a6494835b7710fcfa5d7d8bbe8 (diff)
libnet 1.1.2.1: moved from nonworking by Jamie Lenehan - close #467
Diffstat (limited to 'packages/libnet/libnet_1.1.2.1.bb')
-rw-r--r--packages/libnet/libnet_1.1.2.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/packages/libnet/libnet_1.1.2.1.bb b/packages/libnet/libnet_1.1.2.1.bb
new file mode 100644
index 0000000000..9879008474
--- /dev/null
+++ b/packages/libnet/libnet_1.1.2.1.bb
@@ -0,0 +1,28 @@
+SECTION = "libs"
+DESCRIPTION = "A packet dissection and creation library"
+HOMEPAGE = "http://www.packetfactory.net/libnet/"
+LICENSE = "BSD"
+PRIORITY = "optional"
+DEPENDS = "libpcap"
+PR = "r0"
+
+SRC_URI = "http://www.packetfactory.net/libnet/dist/libnet-${PV}.tar.gz \
+ file://support-uclibc.patch;patch=1 \
+ file://fix-endianess-test.patch;patch=1 \
+ file://configure.patch;patch=1"
+
+S = "${WORKDIR}/libnet"
+
+inherit autotools binconfig
+
+CPPFLAGS_prepend = "-I${S}/libnet/include "
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage () {
+ oe_runmake -C src 'DESTDIR=${STAGING_LIBDIR}' 'libdir=' install-libLIBRARIES
+ oe_runmake -C include 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-includeHEADERS
+ oe_runmake -C include/libnet 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-libnetincludeHEADERS
+}