summaryrefslogtreecommitdiff
path: root/packages/libnet/libnet_1.1.2.1.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-11-11 18:22:30 +0000
committerMichael Lauer <mickey@vanille-media.de>2006-11-11 18:22:30 +0000
commit4eb54f079356de0e82ff98cfc68a3ab254b38351 (patch)
tree3e8fe453dc0f031e93b1d71860ffb1c02448e267 /packages/libnet/libnet_1.1.2.1.bb
parentd6ed5ee9f9682d7de5012fac6528f46675cfb43c (diff)
parent01b752a6cdf62a513886bd89bf649980f8ab1862 (diff)
merge of a83b40dbdf522cf477298e73d789074887799468
and e2fde1c5cf87c2b0a9be2dfac2a1a1937db68382
Diffstat (limited to 'packages/libnet/libnet_1.1.2.1.bb')
-rw-r--r--packages/libnet/libnet_1.1.2.1.bb41
1 files changed, 19 insertions, 22 deletions
diff --git a/packages/libnet/libnet_1.1.2.1.bb b/packages/libnet/libnet_1.1.2.1.bb
index c28b98a304..92457a8ff4 100644
--- a/packages/libnet/libnet_1.1.2.1.bb
+++ b/packages/libnet/libnet_1.1.2.1.bb
@@ -1,41 +1,38 @@
-SECTION = "libs"
DESCRIPTION = "A packet dissection and creation library"
HOMEPAGE = "http://www.packetfactory.net/libnet/"
-LICENSE = "BSD"
+SECTION = "libs"
PRIORITY = "optional"
+LICENSE = "BSD"
DEPENDS = "libpcap"
-PR = "r0"
-
# There are major API changes beween libnet v1.0 and libnet v1.1
PROVIDES = "libnet-1.1"
+PR = "r1"
SRC_URI = "http://www.packetfactory.net/libnet/dist/libnet-${PV}.tar.gz \
- file://support-uclibc.patch;patch=1 \
- file://fix-endianess-test.patch;patch=1 \
- file://configure.patch;patch=1"
+ file://support-uclibc.patch;patch=1 \
+ file://fix-endianess-test.patch;patch=1"
S = "${WORKDIR}/libnet"
inherit autotools binconfig
-CPPFLAGS_prepend = "-I${S}/libnet/include "
-
-do_configure() {
- oe_runconf
-}
-
-do_stage () {
- oe_runmake -C src 'DESTDIR=${STAGING_LIBDIR}' 'libdir=' install-libLIBRARIES
- oe_runmake -C include 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-includeHEADERS
- oe_runmake -C include/libnet 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-libnetincludeHEADERS
+do_configure_prepend() {
+ rm -f aclocal.m4 Makefile.am ltmain.sh
}
-
do_install_append () {
- install -d ${D}${datadir}/man/man3/
- install -d ${D}${bindir}
- install -m 0644 ${S}/doc/man/man3/*.3 ${D}${datadir}/man/man3/
- install -m 0755 ${S}/libnet-config ${D}${bindir}
+ install -d ${D}${datadir}/man/man3/
+ install -d ${D}${bindir}
+ install -m 0644 ${S}/doc/man/man3/*.3 ${D}${datadir}/man/man3/
+ install -m 0755 ${S}/libnet-config ${D}${bindir}
+}
+do_stage () {
+ oe_runmake -C src 'DESTDIR=${STAGING_LIBDIR}' 'libdir=' install-libLIBRARIES
+ oe_runmake -C include 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-includeHEADERS
+ oe_runmake -C include/libnet 'DESTDIR=${STAGING_INCDIR}' 'includedir=' install-libnetincludeHEADERS
}
PACKAGES = "${PN}-dev ${PN}-doc"
+
FILES_${PN}-dev += "${bindir}/libnet-config"
+
+CPPFLAGS_prepend = "-I${S}/libnet/include "