summaryrefslogtreecommitdiff
path: root/packages/libiconv/libiconv_1.11.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-05-24 17:34:13 +0000
committerHolger Freyther <zecke@selfish.org>2007-05-24 17:34:13 +0000
commitc2d4f57002933523cebd64df07e3a4384ca6c655 (patch)
tree398f2905b26f7842c79845f2e8662e43c843cf9e /packages/libiconv/libiconv_1.11.bb
parentb14817b1d05d06f5deb04c8bc79e359c874deb62 (diff)
packages/libiconv: Battle libiconv to not use a rpath (and fix the uclibc build)
-Update libiconv to 1.11 (the latest) -We do not package the LD_PRELOADable libiconv stub -Try hard to disable the rpath issue and. --disable-rpath doesn't disable the roath --disable-rpath=no (wasn't tested and if it works....) --enable-relocatable says to imply --disable-rpath but that doesn't work. Also the files can't be regenerated as the Makefile.am doesn't exist and people patch the Makefile.in. As a last resort fail back to some GNU sed to patch *-libtool to make sure that hardcoding of rpaths will fail!
Diffstat (limited to 'packages/libiconv/libiconv_1.11.bb')
-rw-r--r--packages/libiconv/libiconv_1.11.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/libiconv/libiconv_1.11.bb b/packages/libiconv/libiconv_1.11.bb
new file mode 100644
index 0000000000..de87486a87
--- /dev/null
+++ b/packages/libiconv/libiconv_1.11.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "GNU libiconv - libiconv is for you if your application needs to support \
+multiple character encodings, but that support lacks from your system."
+HOMEPAGE = "http://www.gnu.org/software/libiconv"
+SECTION = "libs"
+PRIORITY = "optional"
+NOTES = "Needs to be stripped down to: ascii iso8859-1 eucjp iso-2022jp gb utf8"
+PROVIDES = "virtual/libiconv"
+PR = "r4"
+LICENSE = "LGPL"
+SRC_URI = "ftp://ftp.gnu.org/pub/gnu/libiconv/libiconv-${PV}.tar.gz"
+
+S = "${WORKDIR}/libiconv-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF += "--enable-shared --enable-static --enable-relocatable"
+
+do_configure () {
+ rm -f m4/libtool.m4 libcharset/m4/libtool.m4
+ autotools_do_configure
+
+ # As we do not really regenerate the Makefiles... and they have stale deps to this file
+ touch m4/libtool.m4
+
+ # Fix stupid libtool... handling. rpath handling can't be disabled and the Makefile's can't be regenerated..
+ # (GNU sed required)
+ sed -i s/^hardcode_libdir_flag_spec/#hardcode_libdir_flag_spec/ ${S}/*-libtool
+}
+
+do_stage () {
+ oe_libinstall -so -a -C lib libiconv ${STAGING_LIBDIR}
+ oe_libinstall -so -C lib libiconv_plug_linux ${STAGING_LIBDIR}
+ oe_libinstall -so -a -C libcharset/lib libcharset ${STAGING_LIBDIR}
+ autotools_stage_includes
+}