summaryrefslogtreecommitdiff
path: root/packages/libexif/libexif_0.5.12.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-08-22 16:17:04 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2008-08-22 16:17:04 +0000
commitf56aab883db4a1fde7bd23318ef64a0d6139b6af (patch)
tree8b7ed7adb7a1dace4cb2abe2b8a02790df207d9a /packages/libexif/libexif_0.5.12.bb
parent29115af38fc715fd35cd98176064b89fede86eeb (diff)
libexif & co: it seems that after all, libexif was fine. Don't know why do_qa_staging bailed out for me yesterday. restoring all affected packages from nonworking.
Diffstat (limited to 'packages/libexif/libexif_0.5.12.bb')
-rw-r--r--packages/libexif/libexif_0.5.12.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/libexif/libexif_0.5.12.bb b/packages/libexif/libexif_0.5.12.bb
new file mode 100644
index 0000000000..94f3bee856
--- /dev/null
+++ b/packages/libexif/libexif_0.5.12.bb
@@ -0,0 +1,16 @@
+SECTION = "libs"
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+LICENSE = "LGPL"
+SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_libinstall -a -so -C libexif libexif ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/libexif
+ for X in exif-byte-order.h exif-data.h exif-format.h exif-loader.h exif-tag.h exif-content.h exif-entry.h exif-ifd.h exif-result.h exif-utils.h
+ do
+ install -m 0644 ${S}/libexif/$X ${STAGING_INCDIR}/libexif/$X
+ done
+}