summaryrefslogtreecommitdiff
path: root/packages/libao
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-02-06 02:48:51 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-06 02:48:51 +0000
commitdf9021a741b54e4504ba2e639b582b808994a2b4 (patch)
tree456ac557f011f11d84e71aba6ec8e6f0899d3dd0 /packages/libao
parent951a6530af92b32af59d8c5e637a0462e6698b86 (diff)
parent28ae043187520daaa291ce8fc068dae9aee40334 (diff)
merge of ffcf1e664e4c623df8d1843978006676812e0bca
and e1959e48d26e0499e408ad374dceffa4f1055500
Diffstat (limited to 'packages/libao')
-rw-r--r--packages/libao/libao-alsa_0.8.6.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/libao/libao-alsa_0.8.6.bb b/packages/libao/libao-alsa_0.8.6.bb
new file mode 100644
index 0000000000..4df98e1cca
--- /dev/null
+++ b/packages/libao/libao-alsa_0.8.6.bb
@@ -0,0 +1,27 @@
+LICENSE = "GPL"
+DESCRIPTION = "A cross platform audio library. This is the ALSA plugin."
+HOMEPAGE = "http://www.xiph.org/ao/"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Matthias Goebl <matthias.goebl@goebl.net>"
+DEPENDS = "alsa-lib libao"
+RDEPENDS = "libao2 (>=${PV})"
+PR = "r1"
+
+SRC_URI = "http://downloads.xiph.org/releases/ao/libao-${PV}.tar.gz"
+S = "${WORKDIR}/libao-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-esd --disable-esdtest \
+ --disable-oss \
+ --enable-alsa09 --enable-alsa09-mmap \
+ --disable-arts --disable-nas"
+
+do_stage() {
+ oe_libinstall -so -C src libao ${STAGING_LIBDIR}
+}
+
+PACKAGES = "libao-alsa-plugin libao-alsa-plugin-dev"
+FILES_libao-alsa-plugin= "${libdir}/ao/plugins-2/libalsa*.so"
+FILES_libao-alsa-plugin-dev += "${libdir}/ao/plugins-2/libalsa*.la"