summaryrefslogtreecommitdiff
path: root/packages/libao/libao_0.8.8.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-07 23:32:09 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-07 23:32:09 +0000
commitba4001fe8c00586b71fb1043795e1b99e3234025 (patch)
treece66a6f384b00812ad533d7b8975d5f8a8bd3402 /packages/libao/libao_0.8.8.bb
parentd9a05430e070a497ca4db0a3f8f746fb952b5ecd (diff)
parenta962c31f95cc3e4eb996eff609e973bcd2d2fc5c (diff)
merge of '2b4e1c7a35c118cf363c771f015c4fdfa5f84731'
and '36fe2f5bf87b5a8eedda174012a2e93f8bb5a8f5'
Diffstat (limited to 'packages/libao/libao_0.8.8.bb')
-rw-r--r--packages/libao/libao_0.8.8.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/libao/libao_0.8.8.bb b/packages/libao/libao_0.8.8.bb
new file mode 100644
index 0000000000..88f7c898ec
--- /dev/null
+++ b/packages/libao/libao_0.8.8.bb
@@ -0,0 +1,39 @@
+LICENSE = "GPL"
+DESCRIPTION = "A cross platform audio library"
+HOMEPAGE = "http://www.xiph.org/ao/"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "alsa-lib pulseaudio"
+PROVIDES = "libao-alsa libao-alsa-plugin"
+PR = "r0"
+
+SRC_URI = "http://downloads.xiph.org/releases/ao/libao-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-esd --disable-esdtest \
+ --disable-alsa --enable-alsa09 \
+ --disable-arts --disable-nas \
+ --enable-pulse"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/ao
+ install -m 0644 ${S}/include/ao/ao.h ${S}/include/ao/os_types.h \
+ ${S}/include/ao/plugin.h ${STAGING_INCDIR}/ao/
+
+ oe_libinstall -so -C src libao ${STAGING_LIBDIR}
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ao.m4 ${STAGING_DATADIR}/aclocal/
+}
+
+PACKAGES =+ "${PN}-alsa ${PN}-alsa-dev ${PN}-pulse ${PN}-pulse-dev"
+
+FILES_${PN}-alsa = "${libdir}/ao/plugins-2/libalsa*.so"
+FILES_${PN}-alsa-dev = "${libdir}/ao/plugins-2/libalsa*.la"
+FILES_${PN}-pulse = "${libdir}/ao/plugins-2/libpulse*.so"
+FILES_${PN}-pulse-dev = "${libdir}/ao/plugins-2/libpulse*.la"
+
+FILES_${PN} += "${libdir}/ao/plugins-2/*.so"
+FILES_${PN}-dev += "${libdir}/ao/plugins-2/*.la"
+FILES_${PN}-dbg += "${libdir}/ao/plugins-2/.debug"
+