summaryrefslogtreecommitdiff
path: root/packages/libao/libao-plugin-alsa_0.8.6.bb
diff options
context:
space:
mode:
authorMatthias Goebl <oe@m.goebl.net>2006-02-07 02:16:16 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-07 02:16:16 +0000
commitc0137f047ce68ef14c7cca0b88500146c438eb9e (patch)
tree5ea5868bcfb9ea437ec8c0f83cbb04f7ff236ccf /packages/libao/libao-plugin-alsa_0.8.6.bb
parentca1af768a6c53ba0189e5a4cbff6237a5aff2337 (diff)
libao-plugin-alsa_0.8.6.bb: Rename from libao-alsa_0.8.6 and fix do_stage
- Rename libao-alsa to libao-plugin-alsa and define libao-alsa as provided, because the main package name will be automatically replaced by the main library name with version appended (libao2) - Restrict staging that only the alsa-part will be staged
Diffstat (limited to 'packages/libao/libao-plugin-alsa_0.8.6.bb')
-rw-r--r--packages/libao/libao-plugin-alsa_0.8.6.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/libao/libao-plugin-alsa_0.8.6.bb b/packages/libao/libao-plugin-alsa_0.8.6.bb
new file mode 100644
index 0000000000..30cde27074
--- /dev/null
+++ b/packages/libao/libao-plugin-alsa_0.8.6.bb
@@ -0,0 +1,30 @@
+LICENSE = "GPL"
+DESCRIPTION = "A cross platform audio library. This is the ALSA plugin."
+HOMEPAGE = "http://www.xiph.org/ao/"
+SECTION = "libs"
+PRIORITY = "optional"
+MAINTAINER = "Matthias Goebl <matthias.goebl@goebl.net>"
+DEPENDS = "alsa-lib libao"
+RDEPENDS = "libao2 (>=${PV})"
+PROVIDES = "libao-alsa"
+PACKAGES = "libao-alsa libao-alsa-dev"
+PR = "r2"
+
+SRC_URI = "http://downloads.xiph.org/releases/ao/libao-${PV}.tar.gz"
+S = "${WORKDIR}/libao-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-esd --disable-esdtest \
+ --disable-oss \
+ --enable-alsa09 --enable-alsa09-mmap \
+ --disable-arts --disable-nas"
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}/ao
+ install -d ${STAGING_LIBDIR}/ao/plugins-2
+ oe_libinstall -so -C src/plugins/alsa09/.libs libalsa09 ${STAGING_LIBDIR}/ao/plugins-2
+}
+
+FILES_libao-alsa = "${libdir}/ao/plugins-2/libalsa*.so"
+FILES_libao-alsa-dev = "${libdir}/ao/plugins-2/libalsa*.la"