summaryrefslogtreecommitdiff
path: root/packages/klibc/files
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2008-02-22 20:39:28 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-02-22 20:39:28 +0000
commita502812fd2f097fe0cf69ddc514685e601f0fd9b (patch)
treedb5c290449e049a1b78fddb67c2e009cf49cb5d3 /packages/klibc/files
parent63abf4b57db58cbfb1b1d652f80ce2f81f524fbd (diff)
klibc: update to 1.5 remove old non-working versions
* build shared klibc-utils * set CC="${TARGET_PREFIX}klcc" if you want to compile against klibc
Diffstat (limited to 'packages/klibc/files')
-rw-r--r--packages/klibc/files/install.patch42
-rw-r--r--packages/klibc/files/klibc_kexecsyscall.patch11
-rw-r--r--packages/klibc/files/staging.patch130
3 files changed, 141 insertions, 42 deletions
diff --git a/packages/klibc/files/install.patch b/packages/klibc/files/install.patch
deleted file mode 100644
index b165e8b177..0000000000
--- a/packages/klibc/files/install.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-# These are OE specific patches which make the install stuff work
-# in the OE build environment and fix the problem that the gzip
-# stuff should be all links to one executable but end up being
-# copies
---- klibc-1.1.1/Makefile.orig 2005-12-29 14:20:09.080981353 -0800
-+++ klibc-1.1.1/Makefile 2005-12-29 14:20:25.634022970 -0800
-@@ -61,7 +61,7 @@ local-install: $(CROSS)klcc
- mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)include/$$d ; \
- for r in $(KRNLSRC)/include $(KRNLOBJ)/include $(KRNLOBJ)/include2 ; do \
- [ ! -d $$r/$$d ] || \
-- cp -rfL $$r/$$d/. $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include/$$d/. ; \
-+ cp -rf $$r/$$d/. $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include/$$d/. ; \
- done ; \
- done
- cd $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include && ln -sf asm-$(ARCH) asm
---- klibc-1.1.1/gzip/Makefile.orig 2005-12-29 18:10:00.787869930 -0800
-+++ klibc-1.1.1/gzip/Makefile 2005-12-29 18:11:21.084922705 -0800
-@@ -70,9 +70,12 @@ clean:
- spotless: clean
- rm -f *~
-
--# These should presumably be shared...
- install: all
-- $(INSTALL_EXEC) gzip gunzip zcat $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)bin
-+ $(INSTALL_EXEC) gzip $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)bin
-+ rm -f $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)bin/gunzip
-+ ln $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)bin/gzip $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)bin/gunzip
-+ rm -f $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)bin/zcat
-+ ln $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)bin/gzip $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)bin/zcat
-
- ifneq ($(wildcard .*.d),)
- include $(wildcard .*.d)
---- klibc-1.1.1/klibc/Makefile.orig 2005-12-30 10:39:04.504930675 -0800
-+++ klibc-1.1.1/klibc/Makefile 2005-12-30 10:39:52.755966921 -0800
-@@ -184,6 +184,7 @@ install: all
- $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)lib
- $(INSTALL_EXEC) klibc-`cat $(SOLIB).hash`.so \
- $(INSTALLROOT)$(INSTALLDIR)/$(CROSS)lib
-+ test -z "$(INSTALLROOT)" || \
- $(INSTALL_EXEC) klibc-`cat $(SOLIB).hash`.so \
- $(INSTALLROOT)/$(SHLIBDIR)
-
diff --git a/packages/klibc/files/klibc_kexecsyscall.patch b/packages/klibc/files/klibc_kexecsyscall.patch
new file mode 100644
index 0000000000..9b2dca4738
--- /dev/null
+++ b/packages/klibc/files/klibc_kexecsyscall.patch
@@ -0,0 +1,11 @@
+--- klibc-1.5/usr/klibc/SYSCALLS.def 2007-03-04 02:52:10.000000000 +0100
++++ klibc.clean/usr/klibc/SYSCALLS.def 2008-02-22 17:12:23.663612084 +0100
+@@ -13,6 +13,8 @@
+ #include <asm/unistd.h>
+ #include <klibc/sysconfig.h>
+ #include <bitsize.h>
++#include <asm/kexec.h>
++long kexec_load(void *, unsigned long , struct kexec_segment *, unsigned long );
+
+ /*
+ * Process-related syscalls
diff --git a/packages/klibc/files/staging.patch b/packages/klibc/files/staging.patch
new file mode 100644
index 0000000000..f5ce23af9f
--- /dev/null
+++ b/packages/klibc/files/staging.patch
@@ -0,0 +1,130 @@
+diff -ru klibc.clean/Makefile klibc-1.5/Makefile
+--- klibc.clean/Makefile 2008-02-08 22:37:36.000000000 +0100
++++ klibc-1.5/Makefile 2008-02-15 12:46:48.000000000 +0100
+@@ -33,7 +33,7 @@
+ export PERL := perl
+
+ # Location for installation
+-export prefix = /usr
++export prefix = $(INST)
+ export bindir = $(prefix)/bin
+ export libdir = $(prefix)/lib
+ export mandir = $(prefix)/man
+diff -ru klibc.clean/scripts/Kbuild.install klibc-1.5/scripts/Kbuild.install
+--- klibc.clean/scripts/Kbuild.install 2008-02-08 22:37:36.000000000 +0100
++++ klibc-1.5/scripts/Kbuild.install 2008-02-18 22:36:35.434193918 +0100
+@@ -88,14 +88,11 @@
+ header:
+ $(Q)echo " INSTALL headers + man pages to $(INSTALLROOT)$(INSTALLDIR)"
+ $(Q)mkdir -p $(INSTALLROOT)$(bindir)
+- $(Q)mkdir -p $(INSTALLROOT)$(mandir)/man1
+- $(Q)mkdir -p $(INSTALLROOT)$(SHLIBDIR)
+ $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)
+ $(Q)-rm -rf $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include
+ $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include
+ $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)lib
+- $(Q)mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)bin
+- $(Q)set -e ; for d in linux scsi asm-$(KLIBCARCH) asm-generic $(ASMKLIBCARCH); do \
++ $(Q)-set -e ; for d in linux scsi asm-$(KLIBCARCH) asm-generic $(ASMKLIBCARCH); do \
+ mkdir -p $(INSTALLROOT)$(INSTALLDIR)/$(KLIBCCROSS)include/$$d ; \
+ for r in $(KLIBCKERNELSRC)/include $(KLIBCKERNELOBJ)/include \
+ $(KLIBCKERNELOBJ)/include2 ; do \
+@@ -106,7 +103,6 @@
+ done
+ $(Q)cd $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include && ln -sf asm-$(KLIBCARCH) asm
+ $(Q)cp -rf usr/include/. $(INSTALLROOT)$(INSTALLDIR)/$(KCROSS)include/.
+- $(Q)$(install-data) $(srctree)/klcc/klcc.1 $(INSTALLROOT)$(mandir)/man1/$(KCROSS)klcc.1
+ $(Q)$(install-bin) $(objtree)/klcc/$(KCROSS)klcc $(INSTALLROOT)$(bindir)
+
+ footer: header
+diff -ru klibc.clean/usr/dash/Kbuild klibc-1.5/usr/dash/Kbuild
+--- klibc.clean/usr/dash/Kbuild 2008-02-08 22:37:41.000000000 +0100
++++ klibc-1.5/usr/dash/Kbuild 2008-02-15 12:18:08.000000000 +0100
+@@ -107,5 +107,3 @@
+ $(obj)/arith.c: $(obj)/arith.h
+ $(Q):
+
+-# Targets to install
+-install-y := sh.shared
+diff -ru klibc.clean/usr/gzip/Kbuild klibc-1.5/usr/gzip/Kbuild
+--- klibc.clean/usr/gzip/Kbuild 2008-02-08 22:37:42.000000000 +0100
++++ klibc-1.5/usr/gzip/Kbuild 2008-02-15 12:18:24.000000000 +0100
+@@ -21,5 +21,3 @@
+ # Cleaning
+ targets := gzip gzip.g gunzip zcat
+
+-# Targets to install
+-install-y := gzip gunzip zcat
+diff -ru klibc.clean/usr/kinit/fstype/Kbuild klibc-1.5/usr/kinit/fstype/Kbuild
+--- klibc.clean/usr/kinit/fstype/Kbuild 2008-02-08 22:37:40.000000000 +0100
++++ klibc-1.5/usr/kinit/fstype/Kbuild 2008-02-15 12:26:20.000000000 +0100
+@@ -21,5 +21,3 @@
+ # Cleaning
+ clean-dirs := static shared
+
+-# install binary
+-install-y := $(shared-y)
+diff -ru klibc.clean/usr/kinit/ipconfig/Kbuild klibc-1.5/usr/kinit/ipconfig/Kbuild
+--- klibc.clean/usr/kinit/ipconfig/Kbuild 2008-02-08 22:37:40.000000000 +0100
++++ klibc-1.5/usr/kinit/ipconfig/Kbuild 2008-02-15 12:26:33.000000000 +0100
+@@ -27,5 +27,3 @@
+ # Cleaning
+ clean-dirs := static shared
+
+-# install binary
+-install-y := $(shared-y)
+diff -ru klibc.clean/usr/kinit/Kbuild klibc-1.5/usr/kinit/Kbuild
+--- klibc.clean/usr/kinit/Kbuild 2008-02-08 22:37:40.000000000 +0100
++++ klibc-1.5/usr/kinit/Kbuild 2008-02-15 12:18:43.000000000 +0100
+@@ -33,5 +33,3 @@
+ subdir- := fstype ipconfig nfsmount resume run-init
+
+
+-# install binary
+-install-y := kinit kinit.shared
+diff -ru klibc.clean/usr/kinit/nfsmount/Kbuild klibc-1.5/usr/kinit/nfsmount/Kbuild
+--- klibc.clean/usr/kinit/nfsmount/Kbuild 2008-02-08 22:37:40.000000000 +0100
++++ klibc-1.5/usr/kinit/nfsmount/Kbuild 2008-02-15 12:26:46.000000000 +0100
+@@ -23,5 +23,3 @@
+
+ clean-dirs := static shared
+
+-# Install binary
+-install-y := $(shared-y)
+diff -ru klibc.clean/usr/kinit/resume/Kbuild klibc-1.5/usr/kinit/resume/Kbuild
+--- klibc.clean/usr/kinit/resume/Kbuild 2008-02-08 22:37:39.000000000 +0100
++++ klibc-1.5/usr/kinit/resume/Kbuild 2008-02-15 12:27:01.000000000 +0100
+@@ -26,5 +26,3 @@
+ # Cleaning
+ clean-dirs := static shared
+
+-# install binary
+-install-y := $(shared-y)
+diff -ru klibc.clean/usr/kinit/run-init/Kbuild klibc-1.5/usr/kinit/run-init/Kbuild
+--- klibc.clean/usr/kinit/run-init/Kbuild 2008-02-08 22:37:39.000000000 +0100
++++ klibc-1.5/usr/kinit/run-init/Kbuild 2008-02-15 12:27:12.000000000 +0100
+@@ -21,5 +21,3 @@
+ # Cleaning
+ clean-dirs := static shared
+
+-# install binary
+-install-y := $(shared-y)
+Only in klibc-1.5/usr/klibc/arch/arm: klib.list
+diff -ru klibc.clean/usr/klibc/Kbuild klibc-1.5/usr/klibc/Kbuild
+--- klibc.clean/usr/klibc/Kbuild 2008-02-08 22:37:49.000000000 +0100
++++ klibc-1.5/usr/klibc/Kbuild 2008-02-15 12:17:24.000000000 +0100
+@@ -175,5 +175,3 @@
+ $(INSTALLROOT)$(INSTALLDIR)/$(KLIBCCROSS)lib))
+ $(Q)$(install-lib) $(obj)/klibc-$(SOLIBHASH).so \
+ $(INSTALLROOT)$(INSTALLDIR)/$(KLIBCCROSS)lib
+- $(Q)$(install-lib) $(obj)/klibc-$(SOLIBHASH).so \
+- $(INSTALLROOT)$(SHLIBDIR)
+diff -ru klibc.clean/usr/utils/Kbuild klibc-1.5/usr/utils/Kbuild
+--- klibc.clean/usr/utils/Kbuild 2008-02-08 22:37:37.000000000 +0100
++++ klibc-1.5/usr/utils/Kbuild 2008-02-15 12:17:51.000000000 +0100
+@@ -64,5 +64,3 @@
+ # Clean deletes the static and shared dir
+ clean-dirs := static shared
+
+-# install only install the shared binaries
+-install-y := $(shared-y) shared/reboot shared/poweroff