summaryrefslogtreecommitdiff
path: root/packages/kismet/kismet_2005-01-R1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/kismet/kismet_2005-01-R1.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/kismet/kismet_2005-01-R1.bb')
-rw-r--r--packages/kismet/kismet_2005-01-R1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/kismet/kismet_2005-01-R1.bb b/packages/kismet/kismet_2005-01-R1.bb
index e69de29bb2..1ab7048863 100644
--- a/packages/kismet/kismet_2005-01-R1.bb
+++ b/packages/kismet/kismet_2005-01-R1.bb
@@ -0,0 +1,33 @@
+SECTION = "console/network"
+DESCRIPTION = "Kismet is an 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
+HOMEPAGE = "http://www.kismetwireless.net/"
+MAINTAINER = "Graeme Gregory <dp@xora.org.uk>"
+LICENSE = "GPLv2"
+DEPENDS = "expat gmp"
+
+SRC_URI = "http://www.kismetwireless.net/code/kismet-2005-01-R1.tar.gz \
+ file://no-strip.diff;patch=1;pnum=0 \
+ file://no-chmod.diff;patch=1;pnum=0 \
+ file://no-lib-modules-uname-include.diff;patch=1;pnum=0 \
+ file://glibc3.3.2-getopt-throw.diff;patch=1;pnum=0"
+
+
+EXTRA_OECONF = "--with-pcap=linux --disable-setuid"
+
+inherit autotools
+
+do_configure() {
+ oe_runconf
+}
+
+
+do_install_append() {
+ if test -e ${WORKDIR}/kismet.conf; then
+ install -m 644 ${WORKDIR}/kismet.conf ${D}${sysconfdir}/
+ fi
+}
+
+PACKAGES =+ "kismet-sounds"
+FILES_kismet-sounds = "/usr/share/kismet/wav"
+
+CONFFILES_${PN}_nylon = "${sysconfdir}/kismet.conf"