summaryrefslogtreecommitdiff
path: root/packages/keylaunch
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2007-11-26 21:43:54 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2007-11-26 21:43:54 +0000
commit37dd0368bfdbb8b3680b8158d6e4d7bef646ad7f (patch)
treeff7759bb3c75b761969cfb248ad5bd5ed17e8766 /packages/keylaunch
parent9eb0ed8694c66d46172111d3d897b4bbef83fbc4 (diff)
parent7639f2359fb6e8d4c861146b1ed4b1f3833cd75b (diff)
merge of '0c8e229c6b28d5a860d0b3d8d71739f9c9bb18e0'
and 'ed8cc53f61ab5684eccfe6a4732071def8a37424'
Diffstat (limited to 'packages/keylaunch')
-rw-r--r--packages/keylaunch/files/keylaunchrc8
-rw-r--r--packages/keylaunch/files/unbreak-keyevents.patch22
-rw-r--r--packages/keylaunch/keylaunch-conf/.mtn2git_empty (renamed from packages/keylaunch/files/akita/.mtn2git_empty)0
-rw-r--r--packages/keylaunch/keylaunch-conf/80chvt-SUID (renamed from packages/keylaunch/files/80chvt-SUID)0
-rw-r--r--packages/keylaunch/keylaunch-conf/akita/.mtn2git_empty (renamed from packages/keylaunch/files/c7x0/.mtn2git_empty)0
-rw-r--r--packages/keylaunch/keylaunch-conf/akita/keylaunchrc (renamed from packages/keylaunch/files/akita/keylaunchrc)0
-rw-r--r--packages/keylaunch/keylaunch-conf/c7x0/.mtn2git_empty (renamed from packages/keylaunch/files/collie/.mtn2git_empty)0
-rw-r--r--packages/keylaunch/keylaunch-conf/c7x0/keylaunchrc (renamed from packages/keylaunch/files/c7x0/keylaunchrc)0
-rw-r--r--packages/keylaunch/keylaunch-conf/collie/.mtn2git_empty (renamed from packages/keylaunch/files/corgie/.mtn2git_empty)0
-rw-r--r--packages/keylaunch/keylaunch-conf/collie/keylaunchrc (renamed from packages/keylaunch/files/collie/keylaunchrc)0
-rw-r--r--packages/keylaunch/keylaunch-conf/corgie/.mtn2git_empty (renamed from packages/keylaunch/files/husky/.mtn2git_empty)0
-rw-r--r--packages/keylaunch/keylaunch-conf/corgie/keylaunchrc (renamed from packages/keylaunch/files/corgie/keylaunchrc)0
-rw-r--r--packages/keylaunch/keylaunch-conf/husky/.mtn2git_empty (renamed from packages/keylaunch/files/shepherd/.mtn2git_empty)0
-rw-r--r--packages/keylaunch/keylaunch-conf/husky/keylaunchrc (renamed from packages/keylaunch/files/husky/keylaunchrc)0
-rw-r--r--packages/keylaunch/keylaunch-conf/keylaunchrc31
-rw-r--r--packages/keylaunch/keylaunch-conf/shepherd/.mtn2git_empty (renamed from packages/keylaunch/files/spitz/.mtn2git_empty)0
-rw-r--r--packages/keylaunch/keylaunch-conf/shepherd/keylaunchrc (renamed from packages/keylaunch/files/shepherd/keylaunchrc)0
-rw-r--r--packages/keylaunch/keylaunch-conf/spitz/.mtn2git_empty0
-rw-r--r--packages/keylaunch/keylaunch-conf/spitz/keylaunchrc (renamed from packages/keylaunch/files/spitz/keylaunchrc)0
-rw-r--r--packages/keylaunch/keylaunch-conf_2.0.10.bb27
-rw-r--r--packages/keylaunch/keylaunch_2.0.10.bb36
21 files changed, 88 insertions, 36 deletions
diff --git a/packages/keylaunch/files/keylaunchrc b/packages/keylaunch/files/keylaunchrc
deleted file mode 100644
index 0296db9dad..0000000000
--- a/packages/keylaunch/files/keylaunchrc
+++ /dev/null
@@ -1,8 +0,0 @@
-key=????Pressed XF86AudioRecord:gpe-soundbite record --autogenerate-filename $HOME_VOLATILE
-key=????Pressed XF86Calendar:gpe-calendar
-key=????Pressed telephone:gpe-contacts
-key=????Pressed XF86Mail:gpe-taskmanager
-key=????Pressed XF86Start:~matchbox-remote -desktop
-key=????Pressed XF86PowerDown:~apm --suspend
-key=????Held XF86PowerDown:~bl toggle
-key=????Combine XF86Calendar XF86Start:gpe-keylock
diff --git a/packages/keylaunch/files/unbreak-keyevents.patch b/packages/keylaunch/files/unbreak-keyevents.patch
new file mode 100644
index 0000000000..0a2d58b16a
--- /dev/null
+++ b/packages/keylaunch/files/unbreak-keyevents.patch
@@ -0,0 +1,22 @@
+# HG changeset patch
+# User "Paul Sokolovsky <pfalcon@users.sourceforge.net>"
+# Date 1196027570 -7200
+# Node ID 282176e5c55dba673756b4707716f06a5c8b37e2
+# Parent 833c989472a7987681ea3b8cbd6f9eb77293177a
+We of course still want to receive key events even after subscribing to
+property events. This fixes when keylaunch doesn't receive forwarded
+power buttons events from gpe-login --autolock in its locked state.
+In plain words: now power button works with autolock screen.
+
+diff -r 833c989472a7 -r 282176e5c55d keylaunch.c
+--- a/keylaunch.c Sun Nov 25 22:04:29 2007 +0200
++++ b/keylaunch.c Sun Nov 25 23:52:50 2007 +0200
+@@ -682,7 +682,7 @@ main (int argc, char *argv[])
+ {
+ initialize (argc, argv);
+
+- XSelectInput (dpy, DefaultRootWindow (dpy), PropertyChangeMask);
++ XSelectInput (dpy, DefaultRootWindow (dpy), PropertyChangeMask | KeyPressMask | KeyReleaseMask);
+ gpe_launch_monitor_display (dpy);
+
+ signal (SIGCHLD, SIG_IGN);
diff --git a/packages/keylaunch/files/akita/.mtn2git_empty b/packages/keylaunch/keylaunch-conf/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/keylaunch/files/akita/.mtn2git_empty
+++ b/packages/keylaunch/keylaunch-conf/.mtn2git_empty
diff --git a/packages/keylaunch/files/80chvt-SUID b/packages/keylaunch/keylaunch-conf/80chvt-SUID
index e3b4efef5d..e3b4efef5d 100644
--- a/packages/keylaunch/files/80chvt-SUID
+++ b/packages/keylaunch/keylaunch-conf/80chvt-SUID
diff --git a/packages/keylaunch/files/c7x0/.mtn2git_empty b/packages/keylaunch/keylaunch-conf/akita/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/keylaunch/files/c7x0/.mtn2git_empty
+++ b/packages/keylaunch/keylaunch-conf/akita/.mtn2git_empty
diff --git a/packages/keylaunch/files/akita/keylaunchrc b/packages/keylaunch/keylaunch-conf/akita/keylaunchrc
index 9bb64db066..9bb64db066 100644
--- a/packages/keylaunch/files/akita/keylaunchrc
+++ b/packages/keylaunch/keylaunch-conf/akita/keylaunchrc
diff --git a/packages/keylaunch/files/collie/.mtn2git_empty b/packages/keylaunch/keylaunch-conf/c7x0/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/keylaunch/files/collie/.mtn2git_empty
+++ b/packages/keylaunch/keylaunch-conf/c7x0/.mtn2git_empty
diff --git a/packages/keylaunch/files/c7x0/keylaunchrc b/packages/keylaunch/keylaunch-conf/c7x0/keylaunchrc
index e0b729a508..e0b729a508 100644
--- a/packages/keylaunch/files/c7x0/keylaunchrc
+++ b/packages/keylaunch/keylaunch-conf/c7x0/keylaunchrc
diff --git a/packages/keylaunch/files/corgie/.mtn2git_empty b/packages/keylaunch/keylaunch-conf/collie/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/keylaunch/files/corgie/.mtn2git_empty
+++ b/packages/keylaunch/keylaunch-conf/collie/.mtn2git_empty
diff --git a/packages/keylaunch/files/collie/keylaunchrc b/packages/keylaunch/keylaunch-conf/collie/keylaunchrc
index e69de29bb2..e69de29bb2 100644
--- a/packages/keylaunch/files/collie/keylaunchrc
+++ b/packages/keylaunch/keylaunch-conf/collie/keylaunchrc
diff --git a/packages/keylaunch/files/husky/.mtn2git_empty b/packages/keylaunch/keylaunch-conf/corgie/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/keylaunch/files/husky/.mtn2git_empty
+++ b/packages/keylaunch/keylaunch-conf/corgie/.mtn2git_empty
diff --git a/packages/keylaunch/files/corgie/keylaunchrc b/packages/keylaunch/keylaunch-conf/corgie/keylaunchrc
index e0b729a508..e0b729a508 100644
--- a/packages/keylaunch/files/corgie/keylaunchrc
+++ b/packages/keylaunch/keylaunch-conf/corgie/keylaunchrc
diff --git a/packages/keylaunch/files/shepherd/.mtn2git_empty b/packages/keylaunch/keylaunch-conf/husky/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/keylaunch/files/shepherd/.mtn2git_empty
+++ b/packages/keylaunch/keylaunch-conf/husky/.mtn2git_empty
diff --git a/packages/keylaunch/files/husky/keylaunchrc b/packages/keylaunch/keylaunch-conf/husky/keylaunchrc
index e0b729a508..e0b729a508 100644
--- a/packages/keylaunch/files/husky/keylaunchrc
+++ b/packages/keylaunch/keylaunch-conf/husky/keylaunchrc
diff --git a/packages/keylaunch/keylaunch-conf/keylaunchrc b/packages/keylaunch/keylaunch-conf/keylaunchrc
new file mode 100644
index 0000000000..c84fa25137
--- /dev/null
+++ b/packages/keylaunch/keylaunch-conf/keylaunchrc
@@ -0,0 +1,31 @@
+# Format:
+# "key=" <ModState> [<Event>] <Keysym>+ ":" [ <Window> ":" ] <Command>
+# ModState:
+# "????" - any modifier (don't care)
+# "...." - no modifer
+# "*..." - Shift
+# ".*.." - Control
+# "..*." - Alt
+# "...*" - AltGr
+# Shift/Control/Alt/AltGr can be combined (e.g. ".**." == Control+Alt)
+# Event:
+# <empty> - Normal keytouch (short keypress followed by release)
+# Held - Long keytouch (pressed and held for some time)
+# Special Events (use with care):
+# Pressed - Key was just pressed (note: other events may match too, e.g.
+# normal/Held)
+# Released - Key was just released (note: other events may match too)
+# Combine - Several keys pressed together (note: other events may match too)
+# Keysym: One or more (for Combine only) X keysyms
+# Window: Ignored, do not use
+# Command: Command line to execute, if starts with ~, suppress X startup notification
+# (use for non-X apps).
+#
+key=????XF86AudioRecord:gpe-soundbite record --autogenerate-filename $HOME_VOLATILE
+key=????XF86Calendar:gpe-calendar
+key=????telephone:gpe-contacts
+key=????XF86Mail:gpe-taskmanager
+key=????XF86Start:~matchbox-remote -desktop
+key=????XF86PowerDown:~apm --suspend
+key=????Held XF86PowerDown:~bl toggle
+key=????Combine XF86Calendar XF86Start:gpe-keylock
diff --git a/packages/keylaunch/files/spitz/.mtn2git_empty b/packages/keylaunch/keylaunch-conf/shepherd/.mtn2git_empty
index e69de29bb2..e69de29bb2 100644
--- a/packages/keylaunch/files/spitz/.mtn2git_empty
+++ b/packages/keylaunch/keylaunch-conf/shepherd/.mtn2git_empty
diff --git a/packages/keylaunch/files/shepherd/keylaunchrc b/packages/keylaunch/keylaunch-conf/shepherd/keylaunchrc
index e0b729a508..e0b729a508 100644
--- a/packages/keylaunch/files/shepherd/keylaunchrc
+++ b/packages/keylaunch/keylaunch-conf/shepherd/keylaunchrc
diff --git a/packages/keylaunch/keylaunch-conf/spitz/.mtn2git_empty b/packages/keylaunch/keylaunch-conf/spitz/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/keylaunch/keylaunch-conf/spitz/.mtn2git_empty
diff --git a/packages/keylaunch/files/spitz/keylaunchrc b/packages/keylaunch/keylaunch-conf/spitz/keylaunchrc
index 9bb64db066..9bb64db066 100644
--- a/packages/keylaunch/files/spitz/keylaunchrc
+++ b/packages/keylaunch/keylaunch-conf/spitz/keylaunchrc
diff --git a/packages/keylaunch/keylaunch-conf_2.0.10.bb b/packages/keylaunch/keylaunch-conf_2.0.10.bb
new file mode 100644
index 0000000000..aeb9c862ca
--- /dev/null
+++ b/packages/keylaunch/keylaunch-conf_2.0.10.bb
@@ -0,0 +1,27 @@
+RDEPENDS_append_spitz = " display-brightness"
+RDEPENDS_append_akita = " display-brightness"
+RDEPENDS_append_c7x0 = " display-brightness"
+
+SECTION = "gpe"
+LICENSE = "GPL"
+DESCRIPTION = "Device-specific keylaunch configuration"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+PR = "r2"
+
+SRC_URI = " file://keylaunchrc"
+SRC_URI += " file://80chvt-SUID"
+
+do_install () {
+ install -d ${D}${sysconfdir}
+ install -d ${D}${sysconfdir}/X11/Xinit.d
+ install -m 0644 ${WORKDIR}/keylaunchrc ${D}${sysconfdir}/keylaunchrc.matchbox
+ install ${WORKDIR}/80chvt-SUID ${D}${sysconfdir}/X11/Xinit.d
+}
+
+pkg_postinst_${PN}() {
+ update-alternatives --install /etc/keylaunchrc keylaunchrc /etc/keylaunchrc.matchbox 10
+}
+
+pkg_postrm_${PN}() {
+ update-alternatives --remove keylaunchrc /etc/keylaunchrc.matchbox
+}
diff --git a/packages/keylaunch/keylaunch_2.0.10.bb b/packages/keylaunch/keylaunch_2.0.10.bb
index f7d63968ac..2afba67f16 100644
--- a/packages/keylaunch/keylaunch_2.0.10.bb
+++ b/packages/keylaunch/keylaunch_2.0.10.bb
@@ -1,10 +1,7 @@
inherit gpe
-DEPENDS = "virtual/xserver libxtst libxau libxpm libgpelaunch display-brightness"
-
-RDEPENDS_append_spitz = " display-brightness"
-RDEPENDS_append_akita = " display-brightness"
-RDEPENDS_append_c7x0 = " display-brightness"
+DEPENDS = "virtual/xserver libxtst libxau libxpm libgpelaunch keylaunch-conf"
+RDEPENDS = "keylaunch-conf"
SECTION = "gpe"
LICENSE = "GPL"
@@ -14,31 +11,14 @@ DESCRIPTION = "A small utility for binding commands to a hot key.\
computers. You can connect each key to a program of your choice; if the\
program is already running, keylaunch can bring its window to the front\
rather than just running another copy."
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-PR = "r12"
-
-SRC_URI += " file://keylaunchrc"
-SRC_URI += " file://makefile-fix.patch;patch=1"
-SRC_URI += " file://80chvt-SUID"
+PR = "r14"
-do_install_prepend () {
- install ${WORKDIR}/keylaunchrc ${S}/keylaunchrc
-
- install -d ${D}/etc/X11/Xinit.d
- install ${WORKDIR}/80chvt-SUID ${D}/etc/X11/Xinit.d
-}
-
-do_install_append() {
- # yeah I know...this is less than ideal
- mv ${D}/etc/keylaunchrc ${D}/etc/keylaunchrc.matchbox
-}
+SRC_URI += " file://makefile-fix.patch;patch=1 file://unbreak-keyevents.patch;patch=1"
export CVSBUILD="no"
-pkg_postinst_${PN}() {
- update-alternatives --install /etc/keylaunchrc keylaunchrc /etc/keylaunchrc.matchbox 10
-}
-
-pkg_postrm_${PN}() {
- update-alternatives --remove keylaunchrc /etc/keylaunchrc.matchbox
+do_install_append() {
+ # Remove random crap
+ rm ${D}/etc/keylaunchrc
+ rm -rf ${D}/etc/X11/Xinit.d/
}