summaryrefslogtreecommitdiff
path: root/packages/kexecboot/linux-kexecboot-2.6.24/zylonite-boot.patch
diff options
context:
space:
mode:
authorHenry von Tresckow <hvontres@gmail.com>2008-09-04 10:32:46 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-09-04 10:32:46 +0000
commit7eb73dfd5a79abfb7efe71b897c3dbcda6e505f1 (patch)
treee2c818bf08bc5dc00623578beeed9a02f9cc8bf6 /packages/kexecboot/linux-kexecboot-2.6.24/zylonite-boot.patch
parentae63a4dad7b06af132c6ba5bdb5fb98b2231525a (diff)
linux-kexecboot-2.6.24: add new version (mainly for poodle)
Diffstat (limited to 'packages/kexecboot/linux-kexecboot-2.6.24/zylonite-boot.patch')
-rw-r--r--packages/kexecboot/linux-kexecboot-2.6.24/zylonite-boot.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/packages/kexecboot/linux-kexecboot-2.6.24/zylonite-boot.patch b/packages/kexecboot/linux-kexecboot-2.6.24/zylonite-boot.patch
new file mode 100644
index 0000000000..f41928eca5
--- /dev/null
+++ b/packages/kexecboot/linux-kexecboot-2.6.24/zylonite-boot.patch
@@ -0,0 +1,45 @@
+From 04c42f566c68b757fdadf54e0e0f9dfe9f3f9b06 Mon Sep 17 00:00:00 2001
+From: eric miao <eric.miao@marvell.com>
+Date: Tue, 19 Jun 2007 16:42:53 +0800
+Subject: [PATCH] [PATCH] make zylonite boot
+
+1. reuse head-xscale.S for XSC3
+
+2. add a workaround for machine ID assignment, which should be done
+ by boot loader
+---
+ arch/arm/boot/compressed/Makefile | 4 ++++
+ arch/arm/boot/compressed/head-xscale.S | 5 +++++
+ 2 files changed, 9 insertions(+)
+
+Index: linux-2.6-pxa3/arch/arm/boot/compressed/Makefile
+===================================================================
+--- linux-2.6-pxa3.orig/arch/arm/boot/compressed/Makefile 2007-09-24 11:25:57.000000000 +0200
++++ linux-2.6-pxa3/arch/arm/boot/compressed/Makefile 2007-09-24 12:26:53.000000000 +0200
+@@ -40,6 +40,10 @@
+ OBJS += head-xscale.o
+ endif
+
++ifeq ($(CONFIG_CPU_XSC3),y)
++OBJS += head-xscale.o
++endif
++
+ ifeq ($(CONFIG_PXA_SHARPSL),y)
+ OBJS += head-sharpsl.o
+ endif
+Index: linux-2.6-pxa3/arch/arm/boot/compressed/head-xscale.S
+===================================================================
+--- linux-2.6-pxa3.orig/arch/arm/boot/compressed/head-xscale.S 2007-09-24 11:42:27.000000000 +0200
++++ linux-2.6-pxa3/arch/arm/boot/compressed/head-xscale.S 2007-09-24 12:26:02.000000000 +0200
+@@ -33,6 +33,11 @@
+ bic r0, r0, #0x1000 @ clear Icache
+ mcr p15, 0, r0, c1, c0, 0
+
++#ifdef CONFIG_MACH_ZYLONITE
++ mov r7, #(MACH_TYPE_ZYLONITE & 0xff)
++ orr r7, r7, #(MACH_TYPE_ZYLONITE & 0xff00)
++#endif
++
+ #ifdef CONFIG_ARCH_COTULLA_IDP
+ mov r7, #MACH_TYPE_COTULLA_IDP
+ #endif