summaryrefslogtreecommitdiff
path: root/packages/kexecboot/kexecboot_0.4.bb
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-01-27 00:25:39 +0100
committerAndrea Adami <andrea.adami@gmail.com>2009-01-27 23:26:25 +0100
commitddf9f35be9bfd945bfeb5b12b767142b1ac3d786 (patch)
treea505bfc34c173717e98768ce43f6e20ca34c8042 /packages/kexecboot/kexecboot_0.4.bb
parent40c87872fcb4c437f5de9eb227eb3efd8b36f613 (diff)
kexecboot: add new (beta) release 0.4 and add patches from upstream
Diffstat (limited to 'packages/kexecboot/kexecboot_0.4.bb')
-rw-r--r--packages/kexecboot/kexecboot_0.4.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/kexecboot/kexecboot_0.4.bb b/packages/kexecboot/kexecboot_0.4.bb
new file mode 100644
index 0000000000..557c5be4b3
--- /dev/null
+++ b/packages/kexecboot/kexecboot_0.4.bb
@@ -0,0 +1,41 @@
+LICENSE = "GPL"
+PR = "r0"
+DEPENDS = "klibc"
+RDEPENDS = "kexec-static"
+
+inherit autotools
+
+# You can create your own *-img.h by doing
+# ./make-image-header.sh <file>.png HAND
+
+SRC_URI = "http://projects.linuxtogo.org/~jay7/kexecboot-${PV}.tar.gz \
+ file://add-reboot-option.patch;patch=1 \
+ file://scan_devices-top.patch;patch=1 \
+ file://graphical-no-devices.patch;patch=1 \
+ file://switch-cursor-off.patch;patch=1 \
+ file://add-sleep.patch;patch=1 \
+ file://silent-output-hack.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/kexecboot-${PV}"
+
+export CC=${TARGET_PREFIX}klcc
+
+# standard oe cflags don't work with klcc
+export CFLAGS = ""
+export CPPFLAGS = ""
+export LDFLAGS = ""
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 kexecboot ${D}${bindir}/
+
+ install -d ${D}/proc
+ install -d ${D}/mnt
+}
+
+FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
+
+pkg_postinst_${PN} () {
+ ln -sf ${bindir}/kexecboot $D/init
+}