summaryrefslogtreecommitdiff
path: root/packages/kexecboot/kexecboot.inc
diff options
context:
space:
mode:
authorAndrea Adami <andrea.adami@gmail.com>2009-02-04 01:20:19 +0100
committerAndrea Adami <andrea.adami@gmail.com>2009-02-04 01:23:11 +0100
commitf457589a4e74a8ea3f9b03a4cbe0742900da1e78 (patch)
treed5589329f6c908865c646cbc6b9b9b0517f19981 /packages/kexecboot/kexecboot.inc
parent9ca65a4ba59d37f08587c2b149c693500835eb2c (diff)
kexecboot: new recipe and refactoring
- added kexecboot_git.bb - moved most of shared things in kexecboot.inc - reworked kexecboot_0.4.bb -> PR bumped
Diffstat (limited to 'packages/kexecboot/kexecboot.inc')
-rw-r--r--packages/kexecboot/kexecboot.inc39
1 files changed, 39 insertions, 0 deletions
diff --git a/packages/kexecboot/kexecboot.inc b/packages/kexecboot/kexecboot.inc
new file mode 100644
index 0000000000..201d3116d8
--- /dev/null
+++ b/packages/kexecboot/kexecboot.inc
@@ -0,0 +1,39 @@
+LICENSE = "GPL"
+
+DEPENDS = "klibc"
+RDEPENDS = "kexec-static"
+
+inherit autotools
+
+# You can create your own *-img.h by doing
+# ./make-image-header.sh <file>.png HAND
+
+SRC_URI += "file://logo-img.h \
+ file://logo.png \
+ "
+
+export CC=${TARGET_PREFIX}klcc
+
+# standard oe cflags don't work with klcc
+export CFLAGS = ""
+export CPPFLAGS = ""
+export LDFLAGS = ""
+
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/logo-img.h ${S}/res/
+ install -m 0644 ${WORKDIR}/logo.png ${S}/res/
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 kexecboot ${D}${bindir}/
+
+ install -d ${D}/proc
+ install -d ${D}/mnt
+}
+
+FILES_${PN} += " ${bindir}/kexecboot /init /proc /mnt"
+
+pkg_postinst_${PN} () {
+ ln -sf ${bindir}/kexecboot $D/init
+} \ No newline at end of file