summaryrefslogtreecommitdiff
path: root/packages/kexecboot/kexecboot-0.4
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-01-29 00:44:28 +0000
committerGraeme Gregory <dp@xora.org.uk>2009-01-29 01:46:20 +0000
commita1514b599c421d2816e25aabab8578b30303c4ab (patch)
tree9ffb2eff4b769cf1d550670e8ab06a508b10adda /packages/kexecboot/kexecboot-0.4
parent5e9f4fc54664f0f205ea49ed0e89eceaf795a0fd (diff)
kexecboot/kexecboot_0.4.bb : add refreshed patches from Dmitry Baryshkov for
tosa support to kexecboot. Add few more keys that can be used on tosa to select correct variant Signed-off-by: Dmitry Baryshkov <dbaryshkov@gmail.com>
Diffstat (limited to 'packages/kexecboot/kexecboot-0.4')
-rw-r--r--packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch b/packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch
new file mode 100644
index 0000000000..e10d1d70b3
--- /dev/null
+++ b/packages/kexecboot/kexecboot-0.4/kexecboot-tosa.patch
@@ -0,0 +1,15 @@
+Index: kexecboot-0.4/kexecboot.c
+===================================================================
+--- kexecboot-0.4.orig/kexecboot.c 2009-01-29 00:38:21.000000000 +0000
++++ kexecboot-0.4/kexecboot.c 2009-01-29 00:39:05.000000000 +0000
+@@ -566,7 +566,9 @@
+ break;
+ }
+
+- }while(evt.code != 87 && evt.code != 63);
++ }while(evt.code != 87 && evt.code != 63 &&
++ evt.code != KEY_SPACE && evt.code != KEY_ENTER &&
++ evt.code != KEY_HIRAGANA && evt.code != KEY_HENKAN);
+ fclose(f);
+ // reset terminal
+ tcsetattr(fileno(stdin), TCSANOW, &old);