summaryrefslogtreecommitdiff
path: root/packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-01-29 22:16:37 +0000
committerGraeme Gregory <dp@xora.org.uk>2009-01-29 22:18:18 +0000
commitfe90a0854047d064954185c2a4fa331e9ad560b8 (patch)
tree6178b2401408bb1af56a07caa15a3880c55008be /packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch
parent6a6d6bab519aefb44e3d49d305134057adf7539e (diff)
kexecboot_0.4.bb : add patch to always use 16bit writes, this fixes tosa
screen corruption and wont harm other machines
Diffstat (limited to 'packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch')
-rw-r--r--packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch b/packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch
new file mode 100644
index 0000000000..f3405e49d8
--- /dev/null
+++ b/packages/kexecboot/kexecboot-0.4/fb-render-16bit.patch
@@ -0,0 +1,21 @@
+Index: kexecboot-0.4/fb.c
+===================================================================
+--- kexecboot-0.4.orig/fb.c 2009-01-29 22:03:34.000000000 +0000
++++ kexecboot-0.4/fb.c 2009-01-29 22:08:22.000000000 +0000
+@@ -19,7 +19,15 @@
+
+ void fb_render(FB * fb)
+ {
+- memcpy(fb->data, fb->backbuffer, fb->screensize);
++ uint16 *source, *dest;
++ int n = fb->screensize/2;
++
++ source = (uint16 *)fb->backbuffer;
++ dest = (uint16 *)fb->data;
++
++ while (n--) {
++ *dest++ = *source++;
++ }
+ }
+
+ void fb_destroy(FB * fb)