summaryrefslogtreecommitdiff
path: root/packages/kexecboot/initramfs-kexecboot_1.0.bb
diff options
context:
space:
mode:
authorThomas Kunze <thommycheck@gmx.de>2008-08-03 23:58:58 +0000
committerThomas Kunze <thommycheck@gmx.de>2008-08-03 23:58:58 +0000
commitcefb9bb3cb800983851a6b69180df6a93e8b14c2 (patch)
tree250627ae079187c3afdc122de218ddcedb515c28 /packages/kexecboot/initramfs-kexecboot_1.0.bb
parentf75918351173d470e4bfe52d2cc9edab0172c70a (diff)
kexecboot: fix build of initramfs-kexecboot-image
Diffstat (limited to 'packages/kexecboot/initramfs-kexecboot_1.0.bb')
-rw-r--r--packages/kexecboot/initramfs-kexecboot_1.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/packages/kexecboot/initramfs-kexecboot_1.0.bb b/packages/kexecboot/initramfs-kexecboot_1.0.bb
new file mode 100644
index 0000000000..e1337419b8
--- /dev/null
+++ b/packages/kexecboot/initramfs-kexecboot_1.0.bb
@@ -0,0 +1,20 @@
+DESCRIPTON = "A init script that mounts a device and kexecs a new kernel from it."
+PR = "r6"
+RDEPENDS = "kexecboot"
+do_compile() {
+ cat > init.sh << EOF
+#!/bin/sh
+/bin/mount -t proc proc /proc
+/usr/bin/kexecboot -a 270 -i /dev/event0
+EOF
+}
+
+do_install() {
+ install -m 0755 ${S}/init.sh ${D}/init
+ install -d ${D}/proc
+ install -d ${D}/mnt
+}
+
+PACKAGE_ARCH = "all"
+
+FILES_${PN} = "/init /proc /mnt"