summaryrefslogtreecommitdiff
path: root/packages/justreader
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-21 13:40:17 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-21 13:40:17 +0000
commite0a191e234aebe57a84143f2b0bf170236a77f37 (patch)
treec0115b8ec012f2c68dead00484cb238ac9cebc47 /packages/justreader
parentb8f88822e375f2228652ea332257574b7c7784f5 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/21 14:13:30+01:00 local!hrw Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/ into marcinj.local:/home/hrw/zaurus/bb/openembedded 2005/01/21 14:13:06+01:00 local!hrw justreader: fix Settings file location (really fix #204) 2005/01/21 14:11:29+01:00 (none)!koen patch to libpcap to fix dsniff build, courtesy Bob Davies 2005/01/21 14:10:18+01:00 local!hrw transition from libstdc++ to libsupc++ Basically it allow us to drop libstdc++ dependency from some programs. Binaries are getting little bigger but don't depend on ~3.5MiB library. If your package fails during linking you have to add one line to it's .bb file: export OE_QMAKE_LINK="${CXX}" 2005/01/21 14:02:44+01:00 local!hrw we already have freedroid in meta-opie - it's in task-qpe-games as it is not from OPIE 2005/01/21 14:01:28+01:00 local!hrw disabled PARALLEL_MAKE for uae and zroadmap 2005/01/21 11:38:29+01:00 local!hrw Merge bk://oe-devel@oe-devel.bkbits.net/openembedded/ into marcinj.local:/home/hrw/zaurus/bb/openembedded 2005/01/18 18:53:19+01:00 hrw.one.pl!hrw disable PARALLEL_MAKE for opie-tinykate BKrev: 41f106415qu3LUbzxrhFJByjZfa8pQ
Diffstat (limited to 'packages/justreader')
-rw-r--r--packages/justreader/justreader_2.0k.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/justreader/justreader_2.0k.bb b/packages/justreader/justreader_2.0k.bb
index e69de29bb2..117e747167 100644
--- a/packages/justreader/justreader_2.0k.bb
+++ b/packages/justreader/justreader_2.0k.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "An E-Books reader for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+HOMEPAGE = "http://justreader.sourceforge.net/"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/justreader/justreader_${PV}.tgz \
+file://correct-settings-path.patch;patch=1"
+
+S = "${WORKDIR}/TextReader2"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST = 'INCLUDEPATH+="${STAGING_INCDIR}/qpe" LIBS+=-lqpe'
+export OE_QMAKE_LINK="${CXX}"
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+ install -d ${D}/${palmtopdir}/bin \
+ ${D}/${palmtopdir}/pics/${PN}/ \
+ ${D}/${palmtopdir}/apps/Applications
+ install -m 0644 apps/Applications/justreader.desktop ${D}/${palmtopdir}/apps/Applications/
+ install -m 0755 bin/justreader ${D}/${palmtopdir}/bin/
+ install -m 0644 pics/* ${D}/${palmtopdir}/pics/justreader/
+}