summaryrefslogtreecommitdiff
path: root/packages/jpeg/jpeg_6b.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2006-01-03 01:56:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-01-03 01:56:36 +0000
commit6c2b02774fe3346deaa75b113abca354e32bf361 (patch)
tree1977b335655516945f925b72bec091cc85f2922b /packages/jpeg/jpeg_6b.bb
parentcc1a6a9afb03af5263be8dfa7c50e12c6f2b7816 (diff)
jpeg: change to use autotools_stage_all in 6b
- native and cross changed. do_install is no longer required as - a patch has been added to fix the failure of the Makefile install - to create the target directory.
Diffstat (limited to 'packages/jpeg/jpeg_6b.bb')
-rw-r--r--packages/jpeg/jpeg_6b.bb17
1 files changed, 4 insertions, 13 deletions
diff --git a/packages/jpeg/jpeg_6b.bb b/packages/jpeg/jpeg_6b.bb
index 49e0382b6e..277cdfa48c 100644
--- a/packages/jpeg/jpeg_6b.bb
+++ b/packages/jpeg/jpeg_6b.bb
@@ -1,3 +1,4 @@
+PR = "r1"
SECTION = "libs"
PRIORITY = "required"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
@@ -9,7 +10,8 @@ LICENSE ="jpeg"
SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
file://debian.patch;patch=1 \
file://ldflags.patch;patch=1 \
- file://paths.patch;patch=1"
+ file://paths.patch;patch=1 \
+ file://install.patch;patch=1"
S = "${WORKDIR}/jpeg-${PV}"
inherit autotools
@@ -20,16 +22,5 @@ EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR}/${HOST_SYS}-libtool"'
CFLAGS_append = " -D_REENTRANT"
do_stage() {
- install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
- install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
- install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
- install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
- install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
- oe_libinstall -so libjpeg ${STAGING_LIBDIR}
-}
-
-do_install() {
- install -d ${D}${bindir} ${D}${includedir} \
- ${D}${mandir}/man1 ${D}${libdir}
- oe_runmake 'DESTDIR=${D}' install
+ autotools_stage_all
}