summaryrefslogtreecommitdiff
path: root/packages/javasqlite/javasqlite_20080130.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2008-07-13 22:42:06 +0000
committerRobert Schuster <thebohemian@gmx.net>2008-07-13 22:42:06 +0000
commit9e850f378107c3b96ebb3ac2018f38d2c04045c5 (patch)
tree1d73c83a175b9dbb33e51517d7d770b05f56f8be /packages/javasqlite/javasqlite_20080130.bb
parent0b3754be53b8afbe6c7aa1ca3cd11b797f07a9c3 (diff)
parente2dea6bc51c47e8d3e7e8e40b76b12a9d03e4309 (diff)
merge of '01bddb578c9dd04edfbb56d0c1c15f81b4161479'
and '400e8684128097359c7f2556772f3c2e15c3e752'
Diffstat (limited to 'packages/javasqlite/javasqlite_20080130.bb')
-rw-r--r--packages/javasqlite/javasqlite_20080130.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/packages/javasqlite/javasqlite_20080130.bb b/packages/javasqlite/javasqlite_20080130.bb
new file mode 100644
index 0000000000..a8ed2d5017
--- /dev/null
+++ b/packages/javasqlite/javasqlite_20080130.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "JDBC driver for sqlite and sqlite3"
+HOMEPAGE = "http://www.ch-werner.de/javasqlite"
+LICENSE = "BSD"
+
+SRC_URI = "\
+ http://www.ch-werner.de/javasqlite/javasqlite-${PV}.tar.gz \
+ file://build-fix.patch;patch=1"
+
+DEPENDS = "virtual/javac-native fastjar-native classpath-native javasqlite-mkconst-native classpath sqlite sqlite3"
+RDEPENDS_${PN} = "${PN}-jni"
+
+inherit autotools java
+
+# jamvm-native unfortunately contains non-generificed java/lang/reflect classes
+# which are accessed in this package. Work around this by setting the bootclasspath
+# explicitly.
+export JAVACFLAGS="-bootclasspath ${STAGING_DATADIR}/classpath/glibj.zip -source 5.0"
+
+EXTRA_OECONF = " \
+ --with-jni-incdir=${STAGING_INCDIR}/classpath \
+ --with-jardir=${datadir_java} \
+ --with-target-native-libdir=${libdir_jni} \
+ --with-sqlite-incdir=${STAGING_INCDIR} \
+ --with-sqlite-libdir=${STAGING_LIBDIR} \
+ --with-sqlite3-incdir=${STAGING_INCDIR} \
+ --with-sqlite3-libdir=${STAGING_LIBDIR} \
+ --with-java=${STAGING_BINDIR_NATIVE}/java \
+ --with-javac=${STAGING_BINDIR_NATIVE}/javac \
+ --with-jar=${STAGING_BINDIR_NATIVE}/gjar \
+ --with-javah=${STAGING_BINDIR_NATIVE}/gjavah \
+ --with-javadoc=true \
+ "
+
+do_configurepre() {
+ sed -i -e "s|wrong-libtool|${TARGET_SYS}-libtool|" Makefile.in
+}
+
+addtask configurepre after do_patch before do_configure
+
+do_compile_prepend() {
+ # Injects a cross-compiled mkconst binary into the build
+ cp ${STAGING_BINDIR_NATIVE}/javasqlite-mkconst-${PV} native/mkconst
+ touch native/mkconst
+}
+
+PACKAGES = "${PN}-jni"